Problem communicating with ACM 2.0.5

I am having a lot of trouble communnicating with my ACM Quad.  Since I switched over to ACM, I can't communicate with it.  I keep getting bad packet or readpacket read errors in mavlink.  The XBEE doesn't work at all but the USB occasionally works.  I rechecked all connections and am getting 4.95V on my power from the power board.  I reloaded all drivers (labview, USB, etc., and tried reloading the firmware (several times).  I switched my receiver from AR6100 to AR7010 (spektrum) and back.  On the rare occasion I get the motors from beeping at 4 CPS (my other problem), I can't arm them.  I tried manually setting the ESCs to no avail.  Every now and then, I'll get a readout from the sensor display in mavlink but then it locks up and I have to restart it (mavlink).  When I ran the motor test one time I thought things were looking good, motors 0 and 1 (front right and back left - x config) don't spin up, even though they do when I manually set ESC.  I'm getting the fast flash blue for receiver and the GPS eventually goes solid.  I've tried reseting the ARM as I open communications too.  Please, any advice would be greatly appreciated. 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Moderator
    At this point, have you tried uploading and doing the complete setup procedure with an APM bare minimum hardware setup? No ESCs, Mag, GPS plugged in? If that doesn't get it to a point where it will communicate, start going through the library examples and determine what piece of hardware on the APM/IMU is bad or has a problem.

    Hi guys,

    I just tried the latest update of ACM and it seemed to work with both xbee (I have 2X 2.4Ghz 60mw pro modules) and usb - I can get telemetry and use MavLink via xbee etc.

    I did have problems like yours before though with trying to communicate with xbee's so I powered my board with an esc and put an N4001 diode in series with the esc line coming into APM. I also added this stuff to my config file:

    #define GCS_PORT 3
    #define SERIAL3_BAUD 57600

    This seemed to work for me with my gps, magnometer all plugged in as well. I also reset the board and erase the EEPROM every time I upload new code, as I have had a few strange things happen when I don't.

  • Moderator

    Hi Jerry,

    I work up at 90th and Mountain View just off the 101 and Shea. Would you be up for lending me your quad (or just the electronics) over the weekend? I know you've been at this for awhile, but getting another head on the case first-hand couldn't hurt. Let me know and we can meet up tomorrow.

  • 3D Robotics

    For anyone still having trouble connecting via Xbee, please ensure that you're powering APM with an ESC/Lipo, not just USB. USB power is not enough for both APM and an Xbee. (You can sometimes tell that you're browning out because you just get the red C LED blinking dimly and slowly.)



  • Developer

    Jerry, to where you have send your queries? As we have not seen your name on our email lists. Please use contact us on jDrones page to make sure that your queries are saved and tracked properly. If you send private emails etc they are getting lost due there is rather heavy traffic on our private email boxes.


    jDrones, UAV's and more
    R/C UAV and ArduCopter manufacturer and one stop shop. We make your FPV come true.
  • hanks Chris.  You seem to be a decent guy.  Please understand that it's a lot of frustration talking.  I meant what I said but I'm just getting tired of it.  Normally I would have just kept my mouth shut.  I've gone through a lot more time and expense than the initial cost as have a lot of other people, I'm sure. Hopefully, it'll be worth it.  Maybe someday, I'll look back and laugh - it ain't happening right now though.  Good luck.
  • The software seems to be in limbo.  We are being told that Ardupirates is no longer valid as is arducopeter 2.0.  The configurator is no longer supported and we are to use mavlink which seems to be in a state of flux as well (please, check for possible errors in code instead of letting the program abort).   My problem is based on not being able to load a stable version of the software on the board then I'm told to cotact tech support in Thailand.  I have sontacted the folks in Thailand to never hear back.  I guess that if the guy who wrote the software and the guy who designed the hardware are unable to assist, I shouldn't really expect too much from tech support.  I realize you guys are blazing new paths but there are a lot of people out there who paid a lot of money to face a lot of frustration in return. As I said before, I started this thing with a simple problem and I've seen at least a half dozen other people chime in with similar malidies.  As I also said, 50hz pulses don't just happen - I know that.  They are made.  My XBee wasn't communicating with the board but if I connected it to an arduino test fixture, it worked great.  Perhaps someone is trying to make too much money off too many people (hex, octo, hil, etc.).  Maybe it would be better to work on a single topic and get it right, then move on.  I'd wait if mine wasn't first in line if it meant having a stable (I've heard this called that name) working product.  I worked long enough in the software industry to know that beta testers are appreciated but if one starts a blog that stretches to 11 pages,it was in my best interest to pay attention to his problem and resolved it, as it was usually an indication that others were experiencing the same thing.  I took the day off today so I could communicate with individuals who always seemed to be gone once I got home from work and were able to try their suggestions only to not hear a word out of them.  I hope at least others are able to get their problems resolved. 
  • 3D Robotics
    Just bad timing, I'm afraid. By choosing to beta test the next gen software you ended up right on the bleeding edge. We love our beta testers, but typically they're experienced users with well tested hardware. We definitely don't exepect new users to start with beta code!

    Project status is always on the News page on the project Google Code home page, with the manual.

    In tje meantime I really recommend that you contact jdrones tech support and get them to walk you through the setup. That's what they're there for!
  • Yah, that's one version of the same problem I've had.  Good luck.
  • I've finally got things working with GCS/Mavlink/AC2. It is possible that my problems were unique to me, but maybe it will help someone.

    First of all, my reset sequence was hanging at the Barometric Pressure Sensor initialization (thanks for the tip Michael). I then saw that it only happened if I had the GPS unit connected. If I disconnected the GPS unit, the BMP085 would initialize and MAVlink would connect etc.

    I then updated the MediaTek GPS with the latest firmware (1.6). With that update, the reset process didn't hang when initializing the Pressure sensor, MAVlink connected and now everything is working together (GCS/sensor-view/planner).

    So, in summary, my problem was that I didn't have the latest firmware on the MediaTek GPS.

This reply was deleted.