Problem in pitch shake

3691164472?profile=original

Hello,everybody here,there is a problem in my flying wing plane x8:


The plane takes off by the launcher.After the auto tune of the PID,the config file is attached below:

config.param

And the flight plan is include in the wp file:

wp.txt


The log file :2014-09-26%2007-33-58.bin

After the taking off,the shake in the pitch shows as follow.Can anybody help analyze the reason.Thanks!

3691164416?profile=original

2014-09-26 07-33-58.bin

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I had this problem and eliminated it by switching to ELEVON_OUTPUT from ELEVON_MIXING. I believe there is a bug related to the behavior of the elevon mixing mode; the developers have clearly marked the elevon mixing feature as deprecated in 3.3, so it is unlikely you'll get help from them about this.

    Now, in fairness, I also switched from APM 2.6 to a Pixhawk at the same time, and I went from Plane 3.2 to 3.3. So this is hardly a controlled experiment I conducted. But everyone else who has complained of this issue is running ELEVON_MIXING, not ELEVON_OUTPUT, including Zheng here. (Has anyone had this problem in ELEVON_OUTPUT? Correct me if so!)

    I hope this helps. If you try switching modes, please reply and tell us how it went. This problem haunted me for weeks.

    • I have the same problem with ELEVON_OUTPUT (the new sytyle) with a X-6 Skywalker. The first time appeared the problem because there was slop in my elevon linkages. But a few days later I have registered the same problem, and now I sure that the linkages are fixed.

      I used V3.4 Plane. 

      Any ideas to improve this behaviour?

      • Moderator

        Have you done an autotune?

        There is another phenomenon called "zagi flap" caused by not enough stiffness in a foam wing, this is an oscillation when a wing goes fast appearing as if the wing tips stay stationary and the center flaps up and down. It destroyed a wing of mine some years ago flying too fast. http://www.rcgroups.com/forums/showthread.php?t=20992, not sure if this is the problem in these cases but all my flying wings have flown with APM:Plane with no sign of this happening.

        • It was an structural problem (the carbon beam was partialy broken) added to bad connection in the ESC. The solution has been a new frame and new ESC. 

          However, now I have problems with take off (I attach the log). When I do a handing launching the plane "overcompensate" the roll (not the pitch as before), and the plane enter in stall.

           

          Maybe this problems is related with my first problem?

          Thank you!

          2016-01-15 10-05-03.7z

  • Hi...I have same issue...you find the problem???

  • Moderator

    Try increase your Pitch_I to 10% of P (so make it at least 0.120). Also make sure there is absolutely no slop in your elevon linkages

    • hi,Graham,

            Thanks for your reply,I will change the Pitch_i and check the linkages.

             In auto mode,my plane shaked when it climbed to the height(from 0m to 300m).After it reached the height( 300m), it stop shake.

             If  I swith the mode from auto to manual,it will stop the shake.

This reply was deleted.

Activity

DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
8 hours ago
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Saturday
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Thursday
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Wednesday
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Wednesday
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Wednesday
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31
DIY Robocars via Twitter
RT @JoeSpeeds: @chr1sa awesomely scary to see in person as our $1M robot almost clipped the walls as it spun at 140mph. But it was also awe…
Oct 29
DIY Robocars via Twitter
RT @chr1sa: Hey, @a1k0n's amazing "localize by the ceiling lights" @diyrobocars made @hackaday! It's consistently been the fastest in our…
Oct 25
DIY Robocars via Twitter
RT @IMS: It’s only fitting that @BostonDynamics Spot is waving the green flag for today’s @IndyAChallenge! Watch LIVE 👉 https://t.co/NtKnO…
Oct 23
DIY Robocars via Twitter
RT @IndyAChallenge: Congratulations to @TU_Muenchen the winners of the historic @IndyAChallenge and $1M. The first autonomous racecar comp…
Oct 23
DIY Robocars via Twitter
RT @JoeSpeeds: 🏎@TU_Muenchen #ROS 2 @EclipseCyclone #DDS #Zenoh 137mph. Saturday 10am EDT @IndyAChallenge @Twitch http://indyautonomouschallenge.com/stream
Oct 23
DIY Robocars via Twitter
RT @DAVGtech: Another incident: https://t.co/G1pTxQug6B
Oct 23
More…