I am configuring apm2 on my Zephyr2.  I have the throws down to about +-35% on my futaba9c.  In mission planner I configure, and then set the endpoints for each channel.  I save and boot up the plane in manual mode... reduced throws work perfect!  I switch to stabilize mode and the apm2 supplies FULL servo range nearly bending my pushrods.

How do I get stabilize, RTL, automission, (every mode) throw values to match the limits of manual mode?  I want all the flight behaviors to match.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Why not just set up your servos normally?  Is there some advantage to your setup?

    If I understand you right you want the radio calibration to understand that your full range (as sent to the APM) is actually only 70% of what the total range should be?

    If I understand right then it isn't really an issue with the software.  What you should do is set your radio to normal mode (100% range), calibrate it in APM, then switch your range back to +-35%.

  • But that is on apm 1
  • On my zeph it is ok, but I think I had this problem when I tried for the first time. I did some searching on the forum and found that doing radio calibration with full throw and no expo would help.
    I tried and it worked.........I'm not sure about my software version, I bought it preloaded from Udrones a couple of weeks ago.
  • Developer

    Hi Adam,

    I just verified your report and find the same behavior.  I have not looked at elevon mixing since last fall and don't remember this behavior in earlier revisions.

    I have submitted it as an issue to the issue tracker to get it on the dev team's to do list.

This reply was deleted.


Chris Anderson liked Zara Mae Pickering's profile
May 21
Azjeg liked Azjeg's profile
Apr 27
Benewake LiDAR liked Benewake LiDAR's profile
Apr 12
Gremsy liked Gremsy's profile
Mar 12