Problem with executing position hold

I cannot get the PIxhawk to execute position hold in 3.2 or in 3.2rc1

I have this same problem on two copters, each using a different radio (TARANIS)

and each has a Pixhawk, one on 3.2 stable version and one on 3.2rc1

they both do the same thing.  

I have a good enough GPS connection, in fact loiter works, here are some screen captures:

3691174763?profile=original

The image above shows that loiter works, 

The image below shows that although Position Hold is selected and the PWM is within the range, current mode has not changed!   

what is preventing it?

3691174749?profile=original

The image below shows that although indoors the HDOP is below 2, 

3691174870?profile=original

Looking for ideas, solutions... 

I hav attached the flash log from testing on the bench. note that  the GPS sig is not real good being indoors, but adequate I think (HDOP below 2)

43.BIN

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi,
    I have exaclty the same issue for days with my apm 2.6,POSHOLD cant be achieved in AC3.1.5 although HDOP is below 2,and it found 9sattelites!
    (plus in log analyzor it reported that there is no sats found!)
    I would be so grateful if you or anyone here share the ultimate solution of this thread if it has been solved for them.
  • Well glad i could help you :)

    Another thing to remember is: RTL goes up to a specific height you can set in the parameters, and then flies at that height back home, so i recommend you check the height of trees and buildings in your area in case you do a mistake and want to hit that "oh crap" switch and cause the copter to fly into things like lots of DJI Phantom videos online. A tip since you don't fully trust the equipment :)

  • Position is not the same as PosHold. For Position hold the dropdown name is PosHold and is only available in the latest Mission Planner. Update to the latest to see it in the dropdown.

    Latest Mission Planner is version 1.3.17 build 1.1.5472.17896, you can see it at the top of your window.

    Again, "Position" no longer exists and that is why you have flight mode error!

    • Thanks Johnex

      That is great to know, I will install MP 1.3.17 tonight and give it try.

      Thanks

      Richard

      • Also,

        Seems like your compass is not fully calibrated properly, or you have the compass either close to ESC's or motors and needs to be put on a stick high away from any interference, from the "moderate change in mag_field". I recommend you also do the compassmot calibration.

        I think after doing that you will notice a huge improvement in loiter and other modes that use the compass, it will be like someone superglued your machine to the sky :)

        • I will recalibrate them as well, so far though I updated Mission Planner and skipped 1.3.17 and went to 1.3.19 which is standard issue now.  I don't find a PosHold, in the list in the drop down, only Position.  Does it need to be selected somewhere else?

          It seems to me that early in when I found that I couldn't get Position Hold to work, I was on 1.3.17, and I had a suggesting that 1.3.16 might work. So I rolled back, thats why I went to 1.3.19 hoping it would work there.

          I seem to be still stuck trying to get position hold working. with 1.3.16, or 1.3.18 and I think 1.3.17,  I don't have poshold on the menu, and cannot get the mode to change, even though I can confirm that the PWM output does go to the correct range.

          could it be the compass issue, I wonder it the internal compass and external compass are somehow confusing the AP.

          Richard

          I have the compass up on a pole, it is mounted in a QAV540 frame, and the ESC's are pretty far away.

          3702776327?profile=original

          • On the latest Mission Planner it also says the APM version you are on in the title of the window. Make sure it says Arducopter 3.2 and you are not on 3.1.5 still.

            • Hi John.. we are getting somewhere thanks to you..

              On my MAC running XP in Parallels, It says 1.3.19 build 1.1.5503.19823
              ON my Thinkpad windows 8.1 PC, it says 1.3.18 build 1.1.5508.10848


              I did notice something on startup of Mission Planner, I consistently see the following error when starting mission planner: INFO MissionPlanner.Common - getModesList Called System.Xml.XmlException: Root element is missing.

              I get this even though I have loaded different versions of MP

              3702876166?profile=original

              • Hi John

                A more complete view of the error shows a path that is not on my PC, or my MAC.

                C:\users\hog\Documents\VisualStudio2010\Projects\ArduPilotMega\Utilities\ParametersMegadataRepository.cs:line 52

                That path sounds like it shouldn't be there..

                3702903650?profile=original

                • That seems to be like the parser for the Parameters that has an error, exactly why you aren't seeing the correct flight mode.

                  Did you try to delete the entire mission planner folder and installing fresh?

This reply was deleted.

Activity

DIY Robocars via Twitter
yesterday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
Saturday
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
Saturday
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
DIY Robocars via Twitter
RT @chr1sa: Our next @diyrobocars race is going to be outside at a real RC racetrack in Fremont on May 28. Fully autonomous racing, head-to…
Apr 30
DIY Robocars via Twitter
RT @f1tenth: Our Spring 2022 F1TENTH course @PennEngineers is coming to an end with a head-to-head race as a big finale. So proud of our st…
Apr 26
DIY Robocars via Twitter
RT @DanielChiaJH: I wrote a thing! Throughout the development of my @diyrobocars car I've been using @foxglovedev Studio to visualize and d…
Apr 23
DIY Robocars via Twitter
RT @SmallpixelCar: My new car for high speed. Low body, everything ( @NVIDIAEmbedded Jetson Xavier NX, @emlid RTK GPS, IMC) under the deck…
Apr 23
DIY Robocars via Twitter
Apr 21
DIY Robocars via Twitter
RT @f1tenth: F1TENTH Race training setup @PennEngineers for our upcoming ICRA2022 @ieee_ras_icra competition. @OpenRoboticsOrg @IndyAChalle…
Apr 21
DIY Robocars via Twitter
RT @fatcatFABLAB: Proud to be hosting a restarted DIY Robocars NYC Meetup April 26. Come by if you want to talk about and race self-driving…
Apr 17
More…