Hi, I'm trying to connect an Ublox receiver to the APM2 (ArduPlane 2.34), here is what i've done so far :

I've configured the serial port on the chip to only transmit the following messages at 38'400 baud and 4Hz :

UBX-NAV-POSLLH

UBX-NAV-STATUS

UBX-NAV-VELNED

UBX-NAV-SOL (this last message i've tried with and without)

I've saved the config in the flash, unplugged the GPS and used the USB to serial converter of the ground Xbee adapter to double check if the messages were correctly sent. Using u-center i connect at 38'400, everything is ok, all messages are grayed out except from the ones above which are in black.

Now i use the air Xbee adapter (GPS needs 3.3V) to connect the Ublox to the APM2 (wiring 3.3V, GND, TX, RX pins) though the DIYD FTDI GPS adapter cable. (i've also tried to send the UBX data over the Xbees to Zterm on the mac, it works).

I upload the code (AP 2.34) using Arduino relaxpatch, with the following option in the APM_config.h :

#define GPS_PROTOCOL  GPS_PROTOCOL_UBLOX

The board boots, but the orange led (from ABC leds) stays solid (at the end of the calibration process) and the blue led (from ABC leds) doesn't flash as it should on normal startup.

I use command line to run some tests... using the GPS test i only see dots like this :

....................

Adding one by one, one dot every time the Xbee adpater LED flashes when it's sending data.

No GPS data received, everything shows 0 in planner (sats, etc.)

I've also tried to swap Rx and Tx pins...

Any idea on what am I doing wrong ?

Thanks.

Views: 1666

Reply to This

Replies to This Discussion

Setup looks good to me, Let Ublox acquire 6 Sats it will take 20 mins.

If you have battery backup on GPS it will restart much faster as it remembers orbital correction data.

Yes, it is not a problem of acquisition, AssistNow offline data available during all the tests, a couple of seconds to get a fix... Problem must be elsewhere... Maybe different protocol with NEO-6 chips ? More options to add in config when uploading the code through arduino ?... etc.

OK, AssistNow is great to use .(I need a  user name & pw ) I use Assist-Offline (5-days works best for me) How is GPS connected? Can APM see the signals? What port are you using?

Are you sure NAV-INFO message is off?

My HP-60 445  Nvidia chip has stopped  no IDE = no boot, I am attempting to reflowing it today. So I can run U-center.

Verify the port that is required for Ublox on APM2 you many need to specify it in APM_Confg.h

If using a Mag compass it must be enabled with declination set too. Check start up messages with serial monitor in Arduino 23 R see if if GPS enabled  text is is sent?

Thanks Mark !

Yes UBX-NAV-SVINFO is off, here is a capture of the serial port (Logfile.ubx attached) you can open it in u-center to check.

Logging settings are 38400,N,8,1

I have the magnetometer enabled and compass declination is set.

Here is what i have defined in my APM_Config.h file :

# define CONFIG_APM_HARDWARE APM_HARDWARE_APM2

#define HIL_MODE            HIL_MODE_DISABLED

#define GPS_PROTOCOL  GPS_PROTOCOL_UBLOX

About the port, it's plugged into the regular GPS port, and it works with this config when i plug the MTK GPS (of course changing the GPS_PROTOCOL to AUTO).

I've also tried leaving it to AUTO and plug the UBLOX, same thing happen.

When i check on the serial monitor, i don't see anything mentioned about GPS (as opposed to when i plug the MTK)...

When i run the GPS test from the command line, i see a line of dots, each dot appearing simultaneously as the LED of the Xbee adapter flashes (which could be about 4Hz i guess)...

About AssistNow, i've mailed the support but no answer from them, nice ;-)

Thanks.

Attachments:

I have the same problem so i am curious about you find any solution this problem.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service