Problems Flashing Simonk Firmware on HK F-30A using USBASP

Hello everyone, I have just tried to flash the simonk firmware onto my esc's and got this error log in the screen shot below.

We have the right firmware, and even tried older versions getting the same code.
we even tried taking the usbasp off the esc and it gave the same error? do i need a newer version or something?

I appreciate any help i can get

Cheers3691100901?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I had a similar one, but not exactly the same so it might not help.

    I bought what I thought was a usbasp, but it was actually a clone. The standard usbasp drivers wouldn't work with it.

    Looking VERY closely (it physically looked identical, except for something I saw somewhere, don't even remember where, that said it was a UBSASV or something lik that. Look up usbasp clone.

    Couldn't find compatible drivers anywhere, well I found something, but I don't understand Chinese.

    Is your driver UserID correct for usbasp, or have you used it before on other devices?

    Or maybe as simple as a bad solder conection in the USB cable or something.

    • Thanks, I have been soo lost in all of this any help is much apreciated

      I was about to give up andbuy turnigy plush 30A (as they dont need to be flashed)

      I am using a mac so no drivers needed, but i will try selecting the clone in the menu. 

      Did you make your own socket device to connect to the programming pads? or did you buy the 20$ one ?

  • has no one ever had thses issues when flashing a HKf30A ESC with Simonk?

This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
xemone liked Max Gilson's profile
Aug 31
More…