Problems uploading firmware to the APM 2.6

Hi,

I'm doing a first time set up for my 3DR Quad using an APM 2.6 board. I've managed to install the Mission Planner software and the device drivers for the APM. I've set the baud rate to 115200 on both the Com port and in MP and selected the correct Com port in the MP drop-down menu (the MP drop-down doesn't show the APM - only the port number?).
When trying to install the arducopter firmware, it goes through the process of connecting with the APM and then starts downloading the Hex file. I then get a "failed upload" prompt with an error message "Communication Error - no connection".

I've tried using a powered USB hub in case my USB voltage wasn't sufficient, but still have the same problem.

Does anyone have any idea on how to resolve this issue?

Thanks

Ian

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Problem solved - Turned out to be a Windows 7-USB issue on my laptop. Still not sure what is causing the problem, but at least my copter is flying!

    • Hi, Ian. Do you know what was the problem?
      I'm having a very similar one, but with the Pixhawk board. Tried in two computers, changed cable, still the same error.

      Thanks in advance!

      • Hey Seidi,

        I discovered it was a computer specific problem which I never managed to solve. I managed to get the firmware updated using another computer. I've also recently updated the firmware to my new pixhawk FC with no problems (on a different pc). Sorry, not much help, but maybe try another computer with different operating system and see if that helps.

        • Gonna try to update the firmware in another computer. Thanks anyway, Ian.

This reply was deleted.

Activity

sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24
More…