Problems with X8

I have a problem with my new X8 and APM 2.5 and the latest Arduplane firmware.

Whenever I switch to loiter the aircraft loiters but loses altitude fairly rapidly.

I have not had this issue with previous planes I have used the autopilot in, only the X8.

I am not sure whether some of my parameters are incorrect or whether I am doing something wrong with the elevons or what the issue is.

The plane flies well in manual and when I stabilize test it on the ground it behaves as it should.

When in stabilize while flying the plane will always lose altitude unless I adjust the pitch manually.

Should stabilize try and maintain the current altitude or just attempt to stabilize the plane?

I have not tried any other auto modes until I can get the thing to maintain altitude.

I have attached a tlog and if anyone cares to take a look you will see it lose altitude when loiter is engaged twice during the flight until I manually pull it back up again.

The flight does not start until 43% through the log file.

I should also add that when I switch to loiter the throttle drops right back then the plane dives and throttles up.

I am using and airspeed sensor and I have tried both methods available for maintaining altitude.

Hopefully someone can shed some light on the problem.

2013-04-01 08-53-23.tlog

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Moderator

    How is 'level' set up, each time at the field or once on the bench? Could it be that you need to set the 'level' with the nose up a few degrees?

This reply was deleted.

Activity

David Hori liked Isabella Domi's profile
Jan 12
More…