Px4 Testing

I am starting this discussion to post information for  testing the Px4 platform.

Most of the discussion is currently in the APM vs Px4 thread. ArduCopter on the Px4 is a work in progressand has made great progress. I have Arducopter on a Px4 Fmu board hovering now and I am very glad to see the code base integrated into the Stm32 platorm. Ardupilot represents many hours testing and refinement , many thanks to Andrew Tridgell ,Randy Mackay  and the other developers as well as Gary Mcray for the documentation  on the Wiki

The Px4 can support a Quad with 4 Motors using only the Px4_FMu board with some of its Usart pins defined as Pwm outputs or using the Px4_Io board to supply Pwm motor (servo) outputs. The configuration with the Io board may work better at the moment , the Fmu only has a number of issues to get booted up  configured and running. It may be that all the testing at the moment is being done with boards that use the Px4_Io.

The Px4  usb is software driven not a ftdi chip like the Apm and has given problems but is working now . When the Stm32 bootloader starts it creates a Usb port with its own Id and sets up a DFU device for loading. If no bootloader request is received it jumps to the code startup and creates a usb serial port with a different USB Id for a mavlink connection. Windows drivers have to deal with the Usb connection and connect the appropiate driver.

I think the Px4 vs Apm  answer is that it is still early in the Px4 development but shows great promise.

 

 

 

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I've updatet to the latest FW (Hexa / 08.05.). After some tries, I could connect to terminal. I goes to setup and enter motors. But there are no motors spins. I also pushed the ARM-Button and retried this (3 short and the other one with continous blinking).

    If I pressed "any key" to break, it needs a few seconds. The ESC are correctly connected, lipo is full. :-/

    Other commands like level works fine.

  • I still can't connect to stand-alone PX4FMU, to a point I'm thinking there's something wrong with my board :( Is anyone able to connect reliably in any way ?

    -Shorting usart1 tx/rx (either on multi port or expansion bus) doesn't work.

    -I connect via ftdi and can see nsh> but CR trick isn't working either.

    -Tried updating boot loader, was already rev3 but flashed in case it got corrupted.

    I doupt its my usb, I am able to connect to px4's mavlink if I start manually.

    Don't think its my MP, it connects fine to apm1/apm2.5.

    Also tried with PX4IO plugged in, which worked only once right after the PX4IO flashing and never again. usart-txrx-short trick didn't work either.

  • Hi,

    I am back again to PX4 arena.

    Put PX4 on live quad that flew well with APM2.0.

    Upload ArduCopter 3.0.0 rc-1 was successfully done by px4uploader. The accelerometer calibration from CLI is something strange or normal that "accel" command asks routine calibration "flat-right-left-nose up and down back" in every command. ( It looks like they are not remembering calibrated parameters.)

    After that I put "motor" command from CLI. Even my quad setup as x-configuration, motor sequence is going 3-1-2-4 instead of normal 1-4-2-3. I double check the wiring from PX4FMU to ESC connector and found those are correct wiring.

    Actually, the quad tend to flip.

    So, my feeling is that PX4FMU is so strange behavior piece of equipment:p   

  • It Is very odd  the behaviour of the usb  mavlink.   The usb port is created in the px4 software but serial data is not being sent

    On top of this windows usb will get jamed up and will not connect to the port  after it is unpluged while a program like mission planner is connected to it  untill the  usb is  disconnected and connected again which  confuses the issue.

     From Martin's report  about the radio  it sounds like the serial  can get blocked  on other ports as well.   Gary  does not seem to see this so it is a bit troubling  to think that it is just some boards.   My sense is that it is a software issue  like a race condition.

    I seem to be able to  arm and fly  in cases where the link is not outputting  so the main loop is running and the serial is blocked.

    Leaving the board plugged  in to usb for a while to warm it up seems to work for me every time and  connecting the serial 0 console  Rx/tx  togeather  when booting  or  having a ftdi on it  when it boots and sending a cr seems to clear the condition as well.

    These problems aside  I do like the way it flys .

     

     

     

  • I  disconected the GPS and everything else from the FMU and found the mavlink port did not start sending  when   plugging in to the usb if  the Fmu  had been disconnected for about  10- 15 min.  Leaving the Fmu  connected to usb for 10- 20  min and then  reconecting usb it works every time  untill it  is left  powered down for  a while . I am not sure if it is just my board or if others are like this.

     

     

  • I think I've a little problem: I've build described hexa-copter. Yesterday I screwed the props and connected the lipos. I armed the copter and took a really little bit throttle and hold the copter by hand from top. But the motors took so much power. I think this was ended in an accident/crash, if I doesn't hold the copter... The motors are correct connected and the firmware was also correct selected (last one via missionplanner).

    Have anybody an idea?

  • Hey!

    Actual 2.9.1b Hex-Firmware is uploaded, minimOSD, 3DR radio telemetry are installed, declination and radio-controller is configured. All motors runs on, but I've a little problem:

    If I connected it to MP or QGround, the sensors send a moving signal, but the copter stands still. The sensor calibration is still not working at MP (see begin) and therefore I want it to calibrate via CLI. If I connect via terminal (Arduino serial window, MP/terminal or QGround) to the copter, I get data without a final end - I think thats the mavlinkdata. But how I connect to the CLI to calibrate my sensor now? Is there any an howto?

    Best regards

  • With  Fmu   the  only arming is the regular right yaw stick command.

     

  • Hey everyone, nice thread !

    Gary, thanks for the update. I'm really starting to like this board especially now that mavlink/usb starts-up reliably. I did have to reset a couple of times before the updater started doing its thing, but after that it connects without ftdi trick every time.

    I'll be trying it out on a small quad so I'd like to skip PX4IO if possible, any ideas on how to arm a stand alone PX4FMU with no arming switch ?

  • what i found was that when i load the firmware using mission planner the PX4 does not connects to mavlink. but when i upload the firmware using the Quploader the Px4 connects to mavlink with out any issue. although there is delay of 2 seconds before you can see the dat aon mission planner. this is strange.

This reply was deleted.

Activity

Laurie J. Troy liked Jasper Kueppers's profile
Apr 1
Timothy Miller liked Joseph Udofia's profile
Mar 18
More…