QGroundControl on Raspberry Pi 3

Hi experts,

I am new in Raspberry Pi and I am trying to build QGroundControl on Raspberry Pi 3. Does anybody try this?
I installed QT 5.7.1 and download QGroundControl to my RPi 3:

git clone --recursive https://github.com/mavlink/qgroundcontrol.git

I was following steps in:
https://wiki.qt.io/Native_Build_of_Qt5_on_a_Raspberry_Pi


First error: Unsuported Linux toolchain, only GCC 32- or 64-bit is supported
I found in QGCCommon.pri that they check what linux/device type we have and I have linux-rasp-pi-g++ and condition with this is missing there
so I tried to do the same as for linux-rasp-pi2-g++

and I got another error in qtcreator while building:
sdl2 development package not found, I installed it with apt-get install libsdl2-dev

I also downloaded source code from
https://github.com/mavlink/qgroundcontrol/releases, but when I try to build it in qtcreator I get error:
MAVLink folder does not exist at ´libs/mavlink/include/mavlink/v2.0´!Run ´git submodule init &&git submodule update´ on the command line.

I tried git submodule init and update also --recursive but not work I got error:
fatal: Not a git repository (or any of the parent directories): .git

So it is error after error, errors everywhere and nothing work. Can somebody help me please?
Big thanks

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I am attempting to install QGroundControl on a Raspberry Pi 3 (running Raspian). I downloaded the compressed archive from the website, but when opening the shell script it encounters an error:

    ..... /home/pi/Downloads/qgroundcontrol/QGroundControl: Syntax error: ")" unexpected

    I even tried this a while ago on a copy of Lubuntu (or something similar) on the Pi3 but it keeps hitting this syntax error.

    Has anyone encountered this error?

    Thanks.

    Jamie
This reply was deleted.

Activity

DIY Robocars via Twitter
Friday
DIY Robocars via Twitter
RT @_JonMyer: 🏎 We need your help in naming my #AWS DeepRacer Underground Track 🏎 @davidfsmith's track is going to be referred to as 𝗔𝗪𝗦 𝗗…
Thursday
DIY Robocars via Twitter
RT @gclue_akira: 仕事もおわったし、電脳化にとらい #マリオカートハック https://t.co/4IU90hCLgm
Thursday
DIY Robocars via Twitter
This is the hashtag to follow all the people in Japan who are hacking the new Nintendo Mario Kart with the real AR… https://twitter.com/i/web/status/1319281354664677376
Thursday
DIY Robocars via Twitter
RT @gclue_akira: @chr1sa @diyrobocars jupyter mario https://t.co/P0oHdjlCRq
Thursday
DIY Robocars via Twitter
RT @_JonMyer: 🚨Our 1st AWS DeepRacer Community Race is Underway on http://twitch.tv/aws 🚨 Join us to find out which member of your commu…
Oct 20
DIY Robocars via Twitter
Oct 19
DIY Robocars via Twitter
RT @BackyardRobotcs: After an admittedly long wait, the new Tinymovr R3.3 motor controller is now available https://tinymovr.com 🥳
Oct 19
DIY Robocars via Twitter
RT @_JonMyer: 🏎 1 hr left before the #AWS #DeepRacer Community 🏎 Top 5 Race tomorrow LIVE on Twitch 1st Place = $50 Amazon GC or AWS Credit…
Oct 19
DIY Robocars via Twitter
Oct 16
DIY Robocars via Twitter
Oct 15
DIY Robocars via Twitter
Oct 14
DIY Robocars via Twitter
RT @davidfsmith: Race virtually with The AWS DeepRacer Community Race and then join us on the track to see how your times compare on the ph…
Oct 14
DIY Robocars via Twitter
Oct 14
Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
DIY Robocars via Twitter
RT @breadcentric: It's now!
Oct 13
More…