QGroundControl on Raspberry Pi 3

Hi experts,

I am new in Raspberry Pi and I am trying to build QGroundControl on Raspberry Pi 3. Does anybody try this?
I installed QT 5.7.1 and download QGroundControl to my RPi 3:

git clone --recursive https://github.com/mavlink/qgroundcontrol.git

I was following steps in:

First error: Unsuported Linux toolchain, only GCC 32- or 64-bit is supported
I found in QGCCommon.pri that they check what linux/device type we have and I have linux-rasp-pi-g++ and condition with this is missing there
so I tried to do the same as for linux-rasp-pi2-g++

and I got another error in qtcreator while building:
sdl2 development package not found, I installed it with apt-get install libsdl2-dev

I also downloaded source code from
https://github.com/mavlink/qgroundcontrol/releases, but when I try to build it in qtcreator I get error:
MAVLink folder does not exist at ´libs/mavlink/include/mavlink/v2.0´!Run ´git submodule init &&git submodule update´ on the command line.

I tried git submodule init and update also --recursive but not work I got error:
fatal: Not a git repository (or any of the parent directories): .git

So it is error after error, errors everywhere and nothing work. Can somebody help me please?
Big thanks

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I am attempting to install QGroundControl on a Raspberry Pi 3 (running Raspian). I downloaded the compressed archive from the website, but when opening the shell script it encounters an error:

    ..... /home/pi/Downloads/qgroundcontrol/QGroundControl: Syntax error: ")" unexpected

    I even tried this a while ago on a copy of Lubuntu (or something similar) on the Pi3 but it keeps hitting this syntax error.

    Has anyone encountered this error?


This reply was deleted.