Quadcopter flips on liftoff


I've seen multiple threads about this topic and have tried most (if not all) documented fixes for this problem.

I build a quadcopter using these parts:

Pixhawk Advanced AutopilotUblox Neo-7M GPS with Compass (not connected)DT750 Hextronic Outrunner 750kvRotorBits QuadCopter Kit With Modular Assembly SystemProps 2pc CW 2 pc CCW Rotation 12" 4.5 pitchCompact 4000mAh 3S 25C Lipo PackAfro ESC 20Amp Multi-rotor Motor Speed ControllerPPM encoder for PWM signal from the 5ch RC controller


From the threads i've gone through, i have:

  • Made sure that the proper motors are attached to pixhawk in the proper manner (shown in the picture).
  • Made sure that the propellers were spinning in the right direction.
  • Made sure that the clockwise and counter clockwise props are on the right motors (seen in the picture).
  • calibrated the accelerometer in mission planner. Values given when on flat ground is

Pitch: (±0.01 - 0.2). Roll: (±0.01-0.4).

  • Ran motor test to see if vibrations/battery affect accelerometer. They do not.
  • tested over grass and flat concrete.
  • Started with Arducopter 3.01, upgraded to 3.2 to see if the problem might be fixed.
  • Radio gives proper outputs and was calibrated.
  • ESC's are calibrated.
  • Made sure it was in + configuration.
  • Ran motor tests.

A couple of comments about the quad:

  • The pixhawk is not centered on the base, its a little off (towards the back towards motor #4).
  • The weight is pretty well distributed but not perfect.
  • starts flipping at about 50% throttle.
  • always flips towards the corner (between 2 arms, could this mean that there is extra pitch and roll?)
  • using 5 channel controller and a ppm encoder for rc. All channels work (1-5) properly.
  • I have logs, no idea how they work but i just downloaded them from the pixhawk using mavlink.

I've tried fixing this problem for 2 weeks but i cannot find anything wrong with the quad. I've looked at multiple forums and all the solutions were not applicable to my quad (usually configuration problem with props/motors). I'd love some help or any suggestions. 

Thank you.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I've had similar problems, and from the picture you posted it looks to be similar to what mine was; flight controller orientation...  Not sure why no one suggested this...

  • Hello i'm having this problem also my quad flips forward on take off did you fix it

    • I have not fixed the problem yet as i have taken a break from this project.

  • Well without decent logs it's are to tell what's going on.

    If the RC input is wrong then the copter is going to flip Left and Forward because those values need to be at mid value.

    If the PPM encoder is set wrong then that could happen.

    Battery voltage to the Pixhawk is low, below 5volts which doesn't seem right.

    Maybe hook it up to mission planner and make sure pitch and roll are at mid values 1500.




  • Also can you set the battery monitor parameter so we can see the battery voltages.


    Yours is set at 0.


    • I have since set the battery monitor using the wizard and set the parameter to voltage and current. I also made sure the battery was charged.

      I have also tried tuning the PID's to lower values (initially 1.5 then 0.8 , 0.4, 0.2) for roll and pitch but the problem persists (with no change in intensity of flip).

      The problem with the logging of the RCIN is still there where some logs have the RCIN and some don't. I don't really know why. I have included two logs that were taken moments apart where all that was changed was PID values. One has the radio and one does not. In this test i was simply trying to liftoff with not flip (unsuccessful).

      2014-12-15 13-52-05 21.bin.log

      2014-12-15 13-58-51 22.bin.log

  • The logs are not of much use.  It does seem as though things are working and you should have noticed that the correct motor sped up when you tilled the copter.

    I would like you to put 3.2 back on the copter as this is the current stable release.  It also look like the Pixhawk voltage to the controller is low.  It's showing only 4.9 volts instead of the usual 5.1 volts.  Is there possibly something not connected correctly or the battery is not fully charged.

    This maybe causing a brown out condition.




  • Only got 12 seconds worth of logs.  No transmitter input and the motors where idling.

    I see you have 3.2 back on which should be good.

    Try coping the log file right off the Compact Flash card.  You can upload the bin file.

    Because the GPS is not working there's no date and time on the file or in the logs.  No real time clock here.

    That should not be an issue.  With the copter armed and no throttle the copter will disarm in that amount of time.


    Looks like everything is working though.




    • I'm having a weird issue. When I try the experiment you want me to do (left, right, down, up). The quad makes 2 log file for the flight. One always larger than the other. In the larger one there are no RCIN values (even though the quad is responding to the throttle) and smaller one may have rcin values, but only for a small part of the flight.

      Here are 2 flights. the one ending with 11 is the larger file and 10 is the smaller file that is created with it. it is a full flight test with the log bitmask set to nearlyall-ac315. The files in the sd card and the ones downloaded from mavlink are the same.

      2014-12-04 14-37-19 10.bin

      2014-12-04 14-37-22 11.bin

  • Moderator


    I know everyone has been working hard to help you figure this out, but I'm afraid your latest log won't be much help. There aren't any RCIN or RCOUT values, so we can't see any roll/pitch vs desired roll/pitch to get an idea if things are setup correctly. Also have you completed all the steps in the Mandatory Hardware Configuration? I and this because some of your RC min/trim/max values look a bit odd, that and the fact that you don't have any flight modes programed.

    Make sure you have completed all the steps in the Mandatory Hardware Configuration then record a log file as Michael suggested here

    Without the props armed and in stabilize run the motors up around 50% leave it alone for say 30 seconds and then tip in the direction of motor 1, then level, then motor 2, then center, then motor 3, then center, then motor 4, then center. Hold each position for say 3-5 seconds each (including center). Set the copter down reduce throttle to zero and disarm then shutdown and download the log.

    I know you've loaded a few different versions of FW and probably just forgot a few steps with this last FW upload. I'm running 3.2 on my Y6B and it's been running great so I don't think you need to worry about the version of FW. Your hardware seems to be setup ok, so I think were looking about something being missed in configuration or orientation.

    Back when you were first trying to get in the air were you really timid on the throttle when trying to get it in the air? As someone already pointed out, if you are too timid when trying to get off the ground you can get into a situation where some of the legs are off the ground and others aren't, this confuses the FC and can result in a flip. You want to get all legs off the ground quickly so the FC can do it's job!

    Finish you setup, run the test and post the new logfile and we'll get it figured out!


    Nathaniel ~KD2DEY

This reply was deleted.