Hello! We need help!

http://diydrones.com/video/2015-10-22-16-17-25-crash

We noticed the strange problem: right after arming yaw suddenly became zero (see the video). Then we switched to auto mode and crashed. Before that we made several successfull flies with the same conditions. Thus this problem is not systematic.

Bin logs say that AHR2 data was correct all the time (lat, lng, alt, yaw). But ATT yaw was calculated with error. So the UAV has lost his home position and all the way tried to return to the wrong calculated position (it keeps the direction of the "home arrow" on the video).

We see that the ATT yaw jumps (green line) whereas AHR2 yaw behaves well (red line):

Copter took off in AUTO mode (it's not obvious by the picture above because of plot zoom). Later we switched to LOITER.

Full bin logs are attached.

Thanks for any help!

Views: 858

Attachments:

Reply to This

Replies to This Discussion

Tried to help you with it, I don't see how you think Yaw  had something to do with the crash, and find it more strange that your IMU2 log have no accelerometer data,  (is that a knockoff pixhawk ?)

Anyway - at first glance it seems you flew in loiter , reducing altitude until you hit terrain or something...    then switched to stabilize.  nothing about flying wrong way to home seems like a cause..

The video would maybe have helped understanding, but the player requires flash, and as we don't live in the 80's , the flash security hole is not installed :)

Andre, thanks for your reply!

You are right! The IMU2 accel data is absent, I didn't notice that, thanks! It's very strange... I watched the previous flights, there are no problems with IMU2 accel. We have already had problems with this pixhawk, not excluded that the problem is on the hardware side. Intend to inspect the PCBs under microscope.

Yes, the video is crucial. It faces the YAW problem and wrong home position calculations (the video recorded from the analog receiver and it contains OSD data). Please try this url, maybe it will work:

https://drive.google.com/file/d/0B4AaYULe7L1OMHQ1VjVUM1RZZzQ/view

Not sure about the yaw, nor do I see the usual signs of bad magnetometer calibration/orientation

You should have switched to stabilize(not loiter), it seems it was perfectly capable of flight.

Yes, I don't see the signs of bad magnetometer too. It seems like some position calculation error.

Have you seen the video?

What do you think about arm-zeroing and jumps of ATT.YAW?

yes I did see the video.

no, I don't think it was a navigation error, position calculations are not exactly bleeding edge stuff, and are very reliable - also, the quad exceeded your WPNAV_LOIT_SPEED of 4m/s 

Watch your ATT.Pitch vs Att.DesPitch  - it's behind all time, but it very often deviates with >13 degrees .

Finally we have not been able to establish the reason of the crash. So we decided to downgrade to the stable copter-3.3.1 firmware.

Hello, I have installed the version 3.4DEV, and is fantastic, I think what happens is that your helicopter GPS is giving wrong positioning, and reviewed the video more than once in stabilized so as tested? I think the problem is that the compass is not pointing north.

Regards.

Antonio

Hi! I think we have found the real cause of the crash. Andre was right pointing on the problem with IMU2 with wrong accel data (rather, the complete lack of data). ARMING_CHECK was totally disabled, that is why we didn't get BAD ACCEL HEALTH on the start.

The problem is partly solved, but still relevant! Discussed here:

http://diydrones.com/forum/topics/solution-proposal-for-pixhawk-imu...

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service