Hello All,

Lately my Xbee Pro failed during a mission with my Hexa jdrones Arducopter V2.5.3

After the mission, when i tried to connect my APMv1.4 with the 5v power coming out of the Power distribution board, the APM didn't powered on. On removing and closely examining the APM board from sparkfun i noticed that the trace got fried that connected GND on the IN5 pin on the APM. I inserted a jumper and when i connected again with the power from PDB, it powered ON.

I reloaded the firmware V 2.5.3. The problem now is that THE RADIO CALIBRATION IS SHOWING ALL THE BARS (ROLL, PITCH,YAW, THROTTLE, RADIOS 5,6,7,8) BLANK.

Furthermore i noticed that the ATMEL MEGA 328 is overheating on the sparkfun board.

Any suggestions3690927579?profile=original3690927389?profile=original

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Ok i am consolidating all my observations again, for advices from the community, regarding should i rma the apm or troubleshoot it myself with some technicians available with me:

    (a) A trace at IN5 on the ArduPilot Mega Flight controller board that connects to Ground got fried during an ArduCopter Hexa flight. This prevented the board to be powered by the ESC power, the board could only be powered by the USB. We applied a jumper to the fried trace.
    (b) The area beneath the ATMEL MEGA 328 and Mux overheats.
    (c) In the APM mission planner -> APM Setup (plane and quad) -> Radio Calibration, all the bars for Roll, pitch, throttle, yaw, radio5, radio6, radio7 and radio8 are BLANK irrespective of the RC transmitter response. I have tested the RC transmitter/ receiver with servos and they are performing OK. This problem started after the APM flight board trace got fried, before that it was performing ok.
    (d) In terminal -> tests, all the tests are giving some values excluding radio and pwm, which give 0 value on all channels
    (e) When i tried to program the ppm encoder as in http://code.google.com/p/ardupilot-mega/wiki/AVRStudio using "Automated procedure", all the leds i.e. yellow, blue and red leds are ON, But when i try to program it , it says that "Could not enter programming mode"

    3692408146?profile=original
    (f) The red and blue leds are ON when the apm and rc reciver are connected.

  • Developer

    I have 3 boards exactly like this

    I also have one that works fine. 

    It seems you have fried your MUX. Therefore, unless you can do SMU soldering, the board needs to be replaced. Good thing, modular design means you keep the same IMU (I have 4 red boards, but only one blue, the first one). So $65 damage. It's an expensive hobby :-(

  • Only Led powered on the apm red board is the pwr (no mux led etc)3692401676?profile=original

  • Still problem's not solved. Thinking to RMA apmv1.4 to distributor. Another question which one for i should go now APMv1.4 or APM2?

    Since the problem has not been diagnosed as yet, still intimidated by this all happening again :(

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @knightsautoteam: Hi @diyrobocars, we are Orlando's first Autonomous racing club and would love your support. We are hosting our first K…
yesterday
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #14 - #ParkingLotNerds join us January 15th for #AutonomousRacing #RoboRace ⁦@DAVGtec…
Monday
DIY Robocars via Twitter
RT @chr1sa: And after that came our races, 50 in all. This battle between these two Russians was the best we've ever seen -- incredible fig…
Monday
DIY Robocars via Twitter
RT @chr1sa: Before our @DIYRobocars virtual race this weekend, we had a presentation from the team that won the Indy Autonomous Challenge i…
Monday
DIY Drones via Twitter
Dec 12, 2021
DIY Robocars via Twitter
Dec 12, 2021
DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Dec 4, 2021
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25, 2021
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23, 2021
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23, 2021
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20, 2021
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20, 2021
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9, 2021
More…