RFD900, RFD900+ - New long range radio modem

Hi All,

I would like to introduce you to a new radio modem that we developed for very long range datalinks!

http://rfdesign.com.au/RFD900.php

Some of the key features of the RFD900 are as follows:

  • Multi point and point to point link capability.
  • Long range >40km depending on antennas and GCS setup.
  • 2 x RP-SMA RF connectors, diversity switched.
  • 1 Watt (+30dBm) transmit power.
  • Transmit low pass filter.
  • > 20dB Low noise amplifier.
  • RX SAW filter.
  • Passive front end band pass filter.
  • Open source firmware / tools, field upgradeable, easy to configure.
  • Small (30 x 57 x 13 mm), light weight (14.5g).
  • Compatible with 3DR / Hope-RF radio modules.
  • License free use in Australia, Canada, USA, NZ.

 

These modems are designed to support long range applications, while being easy to use and affordable.  

These modems have been flying in various platforms and have demonstrated excellent performance in real applications. 

RFD900 modems are now available at: http://store.rfdesign.com.au

Support within APM planner and the radio configurator from Michael Oborne is already available.

It works seamlessly with APM planner, all radio Mavlink parameters are available.

Update, December 2014:  The RFD900+ with improved specifications is available now at:

http://store.rfdesign.com.au/rfd-900p-modem/

Seppo Saario

rfdesign.com.au

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • RFD900u's are now available at the RFDesign online store!

    Along with cables for APM2.5, Pixhawk and FTDI cables.

    This week quantity is a little limited, but next week, we'll have a bunch available :)

    Will post some more info as we get into more extreme testing on what they can do !

    Cheers,

    Seppo

  • Would dearly love to see a European 433 version of the RFD900u, dear santa.....
  • Hi!,
    It's been a while since posting. We have been working on a new, mid-range modem, the RFD900u for a while.

    We tested the RFD900u V1.0 boards and were happy with everything except 1 trace for the IRQ lines from the radio back into the processor... We missed it in the middle of the mega datasheet for the Si1030. So, we had to release a V1.1 board with the fix.
    However, it let us test everything else on the board and it looks nice.

    Today we received the RFD900u V1.1 boards which are getting loaded next week for trial testing. We are getting a production batch scheduled shortly as well, and plan to have these on the online store in around 3-4 weeks, in stock :)

    The RFD900u is not really a replacement for the RFD900u, rather a complementary modem. It is only 100mW (20dBm), there the RFD900 is 1W (30dBm).

    The RFD900u is suited for mid range apps, not quite as far as the RFD900, but, much further than any of the existing offerings around, in this small size.
    I am estimating range around 10km or so, but, would love to see how far they really go!

    Attached is a picture to show the comparison between the modems. :)

    Hope you like it !
    3692875076?profile=original
    Seppo

  • Thanks Rana. I find the Hirose connector a bit too fragile. Soldered in the more robust headers. It works on all boards.

  • Can the RFD900 TX and RX pins be connected to the UART0 RX and TX headers on the APM 2.5 instead of via the 3DR telemetry cable to the UART/0 ("3DR-RADIO") Hirose connector? As the radio modem chugs up to ~1 A peak at max power, I'm feeding it off its own BEC. 

  • Rana,

    Thanks for the reply. I was eventually able to get the radios to communicate to my computer. In truth I believe the radios were working correctly the entire time, I could see the LED's behave as expected when one radio was on and the second was turned on. The green blinking LED would turn solid and the radios would sync up.

    I was unable to connect to the radios at all through my computer though despite the device showing up on my COM port and USB BUS in the device manager.

    When +++ and ATI5 were sent to the device no response was shown. If I tried to connect in APM Mission Planner the link would timeout and MP would suggest that there was no firmware loaded on the device. I even tried starting the radio in bootloader mode by jumping the bootloader pads but I was still unable to communicate with the device to upload firmware, read settings, or load settings in either the RFD900 modem tool or the 3DR radio calibration tool. 

    The solution was to revert from the most current FTDI driver from this website: http://www.ftdichip.com/Drivers/VCP.htm, version 2.08.30, to the previous version of the driver, 2.08.28.

    I was unable to perform the instructions provided in the startup guide because the link between my computer and the RFD900 was never established.

    I'm not sure which FTDI cable I'm using. It was the cable supplied in the kit I purchased consisting of (2) modems, (4) antennas, and (1) FTDI cable. When I was trying to use the newest driver the FTDI cable was identified by my computer as FT232R USB UART. I can't tell you if that matches the chip or not.

     With the old version 2.08.28 of the driver installed everything appears to be working as expected.

    IMAG0718.jpg

    IMAG0717.jpg

    • Hello Zach. I sent you a request but didn't include why. I ran across this post and wanted to know if you would be so kind to try and assist me with my JDrones RFD900 radios. Can't connect via COM7 57600 and this is what has happened so far:

      1) Ordered radios with Pixhawk FTDI cable

      2) Replaced cable on air radio with Pixhawk cable and connected (get solid green light when craft is powered on)

      3) Connect GS side radio and get blinking green light

      4) Loads settings from GS radio but just a few fields of data (may just be default) of air radio side

      5) Upgraded firmware on GS radio using 3DR radio tool

      6) Installed latest drivers from FTDI site (2.08.28) is no longer listed

      7) Plugged FTDI USB cable into air radio to check settings (based on post I read) but radio can't be found/accessed. Also shows solid green led when plugged into GS via USB cable.

      NOTE: It seems odd that the air radio always has solid green while GS modem blinks. I would think especially connected to GS they would have the same behavior.  Any ideas of where to go next by you or anyone else would be greatly appreciated.

      Thanks

      Jon

      • Jon I'm sure this ins't the case but what the heck... I had similar issues once only come to find out I forgot I had another radio plugged in on another computer so the connections was not working right with 3 radio's at once. Just a thought :]

        • I thought about that too. I have a plane with a couple radios but they are disconnected and not powered on. It seems very odd that I plug in GS radio and get flashing green and can access, unplug and plug in the 2nd and get solid green and no access. Very strange. I checked FTDI cable multiple times and just can't get it to connect.

          Thanks for your response!

          Jon

  • I just purchased these radios and had some trouble getting them to work immediately. I spent quite a bit of time trying to understand what the problem was and eventually found that the newest FTDI driver did not work with the supplied cable and RFD900 radios on any of the (3) computers I attempted to connect with. 

    I didn't see any information on the internet about this so I thought I would share here in case someone else is looking. In order to get the computer to communicate with the radio the FTDI driver from February of 2013 had to be overwritten on top of the most current driver from July 2013.

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #14 - #ParkingLotNerds join us January 15th for #AutonomousRacing #RoboRace ⁦@DAVGtec…
Monday
DIY Robocars via Twitter
RT @chr1sa: And after that came our races, 50 in all. This battle between these two Russians was the best we've ever seen -- incredible fig…
Monday
DIY Robocars via Twitter
RT @chr1sa: Before our @DIYRobocars virtual race this weekend, we had a presentation from the team that won the Indy Autonomous Challenge i…
Monday
DIY Drones via Twitter
Dec 12, 2021
DIY Robocars via Twitter
Dec 12, 2021
DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Dec 4, 2021
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25, 2021
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23, 2021
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23, 2021
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20, 2021
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20, 2021
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Sat Nov 6 Virtual DonkeyCar (and other cars, too) Race. So bring any car? @diyrobocars @IndyAChallenge https://t.co/nZQTff5…
Oct 31, 2021
More…