RFD900, RFD900+ - New long range radio modem

Hi All,

I would like to introduce you to a new radio modem that we developed for very long range datalinks!

http://rfdesign.com.au/RFD900.php

Some of the key features of the RFD900 are as follows:

  • Multi point and point to point link capability.
  • Long range >40km depending on antennas and GCS setup.
  • 2 x RP-SMA RF connectors, diversity switched.
  • 1 Watt (+30dBm) transmit power.
  • Transmit low pass filter.
  • > 20dB Low noise amplifier.
  • RX SAW filter.
  • Passive front end band pass filter.
  • Open source firmware / tools, field upgradeable, easy to configure.
  • Small (30 x 57 x 13 mm), light weight (14.5g).
  • Compatible with 3DR / Hope-RF radio modules.
  • License free use in Australia, Canada, USA, NZ.

 

These modems are designed to support long range applications, while being easy to use and affordable.  

These modems have been flying in various platforms and have demonstrated excellent performance in real applications. 

RFD900 modems are now available at: http://store.rfdesign.com.au

Support within APM planner and the radio configurator from Michael Oborne is already available.

It works seamlessly with APM planner, all radio Mavlink parameters are available.

Update, December 2014:  The RFD900+ with improved specifications is available now at:

http://store.rfdesign.com.au/rfd-900p-modem/

Seppo Saario

rfdesign.com.au

 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies


  • Have 3 set bundle rfd900x but still cant connect by using mission planner or 3dr radio config.

    Try reflash but not affected at all.

    What I have to do for it?

    Thanks


    kent Martin said:

  • Jeremy, yes I'm using SiK firmware versions from 1.5 to 1.12 all communicating nicely.  By that, I mean I might have an aircraft with 1.12 communicating with a ground station running 1.5 or some other version in between, or vice versa.  I'm attaching a screen shot of the settings, they are pretty much the defaults, except for Tx Power and ECC.  As you can see, in this instance, I have a 900+ w/SIK 1.9 on the ground and a 900U w/SIK 1.12 on the aircraft.

    I've read only your last few posts, so I'm not sure what you are up against.

    RFD Settings.jpg

  • Don, are you using SiK firmware and if so what version/settings?

  • Jeremy, my experience has been that the RFD900 works ok with ECC on, but the RFD900+ doesn't.  Seppo told me that the 900+ just couldn't handle the overhead of ECC because of other added features.  ECC has to be set the same on both ends for the transceivers to link.  Since I disabled ECC on all my ground stations and aircraft, my telemetry problems have disappeared.  I've since upgraded the aircraft radios from 3DR to RFD900u devices and couldn't be happier.

  • Kent, Thanks for the suggestion!  I'll try with and without ECC and reducing the number of channels.

    For anyone else also struggling with range issues, here's another (perhaps helpful) discussion from a successful balloon test where Tridge expressly recommends that ECC be turned on to increase range by fixing corrupted packets.  In their specific case it could have increased the range by 50%.  It also had a couple other things I want to try, like reducing the Air Rate (mine is currenlty 64kbps).  I'm also going to try simply using their exact firmware, SiK 1.5.  I think if I can setup my radios literally the same as this test and still have range issues, it limits the problem to hardware (either antenna or radio). 

    Let me know if replicating the test in the post below seem like a bad idea for some reason (maybe some bugs were found in SiK 1.5.)

    http://diydrones.com/profiles/blogs/9xtend-vs-rfd900-radio-high-alt...

  • Jeremy,

    Yes try turning ECC off. In the new version of board I believe we recommend not using that.

    You could also try changing number of channels to 20. 50 won't fit in spectrum without overlap, but will probably work anyway. 

    The most stable version was V1.9 for the 900+ , other versions weren't very stable. Try going to V1.9.

    Kent


    Jeremy Stromsoe said:

    Seppo,  

    Any other suggestions to try?  Short of sending the units back and seeing if I have better luck with a replacement I'm running out of ideas.  One person asked why I have ECC on, to which I would say because I like when packets are corrupted that they might be recovered :).  It also states in the data sheet that this is the default and should be on after a specific code version.  Again, thanks for all your help, let me know if there is a bit more fine level tuning/troubleshooting I can try.  

    Jeremy 

  • ECC

    As I recall ECC has been a bug on all the RFD900 radios. It causes all kinds of random problems and should never be used.

    Maybe that's fixed with the V2.x firmware. I run 2.6 but have never tried ECC.

    .

  • Seppo,  

    Any other suggestions to try?  Short of sending the units back and seeing if I have better luck with a replacement I'm running out of ideas.  One person asked why I have ECC on, to which I would say because I like when packets are corrupted that they might be recovered :).  It also states in the data sheet that this is the default and should be on after a specific code version.  Again, thanks for all your help, let me know if there is a bit more fine level tuning/troubleshooting I can try.  

    Jeremy 

  • 100KM
    1. The antenna you linked to does not specify whether it is SMA or RPSMA connector.  The RFD 900 requires RPSMA.
    2. That antenna is a simple monopole.  It typically needs a ground plane to work properly.  I doubt you will get anywhere near the range you're looking for.


    Jamie Glover said:

    Seppo, could I use this antenna on the RFD 900 and still get 20+ miles or would this antenna harm the unit running it a full power? Im looking for the sleek form factor.

    https://www.readymaderc.com/store/index.php?main_page=product_info&...


  • don't connect tx line out of the OSD  you only need TX into the OSD if you have 2 TX the controller will get confused in who it is talking to


    Jeremy Stromsoe said:

    Jamie, did you figure this out?  I'm also running MinimOSD and it works fine with the RFD900+.  You have to make a "Y" in the cable and send tx/rx wires to both the OSD and the RFD900.

    Jeremy

    Jamie Glover said:

    Seppo, is there a wiring diagram for this, utilizing Minim OSD with it? Im still hunting, but it looks as though I can only use either telem or osd, not both at the same time.. but Im betting thats incorrect. Any ideas where to find a similar setup. Im not trying to fry anything.

     

    Thanks

    Jamie

    PS, I did get the package. I had to track it in USPS after it got state side.

This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…