RTL aggressiveness in 2.9

Is there any way to tune down the aggressiveness of the RTL in 2.9?  With 2.8 I was used to it heading back to launch rather slowly and gently and with 2.9 it does that steep yaw turnaround and comes back really fast, making it quite a nerve racking experience in tight quarters, haha. 

It was easier to jump back to stabilize mode and save if where it wanted to land was in danger of an obstacle but now it seems to be traveling so fast when it gets to / crosses the waypoint.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Not sure if you ever got an answer on this, but this is what I ended up doing.  I had the same problem so I went to the WP_SPEED MAX parameter which was set at 500. I reduced it to 250, I also went to the LAND SPEED parameter which was set at 50 and reduced it to 40. Tested and seems to work. After changing the setting I also checked Stabilize, ALt-hold, Loiter, & Circle and all modes seem to be fine. Hope this helped.

This reply was deleted.

Activity

sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24
More…