Hi All,

I have a problem that am struggle to get around.

When I power up the APM (its the AMP1 I use) and connect to Mission Planner, the altitude in the Flight Data page is relative, and is sitting somewhere in the +/5m range, so for so good. The mision planner shows the Home Location correctly, with the altitude show in absolute form as per the (abs) note by the altitude.


Now If i move my home location manually by clicking on the home circle and dragging, it also behaves fine, although the altitude does change if I move home to lower ground, so assume it is using Google data to correct for ground level. SO far so good.

However if I click the Home location text in the planner page to set Home to the current plane location, the altitude shown for Home gets set to the relative altitude, i.e. close to zero.

I don't believe it should do this as the Home Alt on the planner page is clearly tagged as (abs).

I have attached two jpgs showing before I click and after I have clicked Home location. The home Alt shows a change from 168.9 to 4.

Can anyone help on this. I can't fly until this is sorted as I am not confident in the altitudes being as they seem.

My ealier version of MP from around Easter this year did not do this if my memory serves me correctly.

Thanks for any help


Views: 5543


Reply to This

Replies to This Discussion


First of all, a new 1.2.65 MP has been released which you may want to try. However, it used to work, in the actions tab, Set Home Altitude, you could toggle between relative and absolute alt. I haven't tried it lately though.



Yes I agree it did used to work.

With 1.2.65, the Set Home Alt in the actions tab just toggles between 0 and the relative Alt. It does this even if I have just rebooted the APM, got a good GPS lock, and MP is reporting the correct abs. alt. in the planner page (185m).

Note that my home alt is ~185m abs.


The Set Home Alt in the action tab used to toggle between relative and abs. alt. as you concurred so pretty sure something has been broken in this area of the code. I am using 1.2.65.

This is pretty easy to repeat so hopefully one of the dev gurus will pick up on it from this forum.

I have done around 20 flights with olde revs and have had great success, so hopefully am not on a wild goose chase here.


I had a laptop running 1.2.55 MAV 1.0 so I tried the above, using both the action tab and the Home Location on the planner page and it works spot on, so the issue seems to be post that revision.

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service