I have been trying for the last couple of days to get my ESCS that came preflashed with SimonK firware.


I am using a ar8000 spektrum receiver module. I can not for the life of me get the 4th beep when trying to calibrate the throttle on the ESCs with this receiver. Maybe someone out there has a bit more experience with SimonK and spektrum receivers. Any help from the community is appreciated...



Views: 20577

Reply to This

Replies to This Discussion

Hello! You mean with the stick high, it just makes three increasing beeps, and stops? The only explanation for that would be that either the pulse is never going longer than 1460µs (PROGRAM_RC_PULS), or that calibration is turned off in the source (RC_CALIBRATION=0). Do you have a servo tester or something else you could test with directly to rule out the tx?

I'm not sure which version they ended up using at ZTW, since I think they've been using a version that somebody sent them a while ago. You should be able to read off the binary with the Turnigy USB linker or Afro ESC USB linker, and/or replace it (typically bs_nfet.hex).

I will give it a try but I will also connect the receiver to my multiwii to make sure everything is working on that side as well. I think it should tell me what frequency the transmitter is driving at. Some others used it for a ground based bot before with really specific speed controllers and it might be way out of wack by now.

I'm testing (debugging...) a new Tarot 690 with the same ESC's and might be having problems too..?  When you say you are not hearing a 4th beep I only hear 3 beeps when I do a throttle calibration - two quick beeps - pause - then a long beep.  Am I supposed to hear a 4th beep?

I'm using the Naza V2 with AR8000 and when trying to lift-off there appears to be a problem with either the ESC's or the motors (SunnySky 3508).  The craft tries to flip over upon take-off.  I pulled the Naza out of an earlier 550 hex build so I know how smooth it should lift off.  I just re-soldered all the connections from motors to ESC (removing the bullet connectors) but have not tested yet due to big snow storm here in Colorado.  

Simon - do I need one of these to check the ECS's - http://www.altitudehobbies.com/ztw-brushless-esc-programming-card

Any help would be greatly appreciated!

Please read https://github.com/sim-/tgy/#throttle-calibration-and-programming for calibration and https://github.com/sim-/tgy/#troubleshooting for an explanation of the beeps. What I was trying to explain was the series of start-up beeps versus the start of the first calibration/learning beep. Yes, once you start calibrating, the sequence is different (and can have another step if RC_PULS_REVERSE is set, etc.). It should be pretty obvious if it is doing something or not.

Flying up and not landing easily is usually a sign that there's just too much power at the lowest speed -- usually a sign that the calibration is such that the lowest flight controller output is still too high. However, if you are flipping almost right away, like in this video: http://www.youtube.com/watch?v=4ebl9GewI4k , the problem is likely mis-ordered control wires from the flight board to the ESCs.

The programming card is not supported currently (though I did start support for it a while back). It doesn't read anything, anyway, it only writes settings.

Thank you for your quick reply Simon!  The information you provided was very helpful.  This is my 3rd multi-copter build so I have some experience and that is why this is a bit baffling...  

Yes, my craft flips right away.  When I slowly try to takeoff I can see it is lifting unevenly.  I've even tried to punch the throttle to get it up into the air, but it's just flips over.

I doubled checked the wiring from ESC to each motor to make sure each is spinning correctly - and they are.  To obtain the reverse motor direction on select motors I simply reversed the outer two wires (my config. is V-Hex).  The Naza V2 software allows you to test each motor individually to make sure it's spinning correctly.

I doubled checked the control wires from the ESCs to my Naza - and they are correct.

The frame and all components are tight - the craft is balanced on all axis - props are perfectly balanced.  When I spin up the motors with props on, I don't feel unusual vibration and it sounds good (smooth and quiet).  All motors seem to be running at the same speed.

Therefore this leads me back to your comment about flight control output being too high.  I'm using a Spectrum DX8 and the default setting for Throttle are -100% to +100.  I used these setting to do the ESC throttle calibration.  The controls can go to -150 to 150.  I think I try and re-calibrate using -125% and +100.

Any insights on this problem would be greatly appreciated.

I've been following this thread and I'm interested to see the outcome. Good Luck. It sure sounds like a reversed motor or prop. I'm really curious. 

No it was not a reversed motor or prop problem it was the ESCs.  I could test these with my Naza V2.  The ZTW Spider 30A ESCs did not work with my SunnySky 3508, 580kv motors - at least the ones I purchased...  I was advised to use Hobbywing Platinum 30A Opto's and that fixed it.  It was a pain to pull all the existing ESCs and replace with Hobbywings but in the end it was worth it.  The craft flies perfectly now and I'm getting 12 minutes of flight time on one Turnigy 4S 5000mAh battery.  I wired for parallel battery usage so should get over 20 minutes loaded with ARRIS 3000 gimbal.  Here's my craft:

Hey Simon k,

     Things went really well afterall with the ESCs. I checked all the inputs as well as my multiwii settings and made sure that I was seeing 1000-2000 range and that solved it. Plus whatever person had the remote for the last quad inverted the input so that was not helping me either. I really like the response that your software had and the experience taught me a whole heap about quad rotor architecture. I am working on a quad for a competition which is in 3 weeks. Afterwards I can post the pictures, video and results. So everyone, look forward to my first large blog on this website in a couple weeks. Should be a big one.,

I need some guidance.
Using AR 8000, SS V 700, Spider 30 amp ECS.
Set throttle to max, plug power to esc....I get a few very faint beeps and no power up of receiver.
I have plugged separate battery to receiver with test servo and everything works fine.
I am at a loss to figure this out.
Any suggestions would be appreciated.

A light should appear inside the AR8000 when it has received power.  Light also should appear in the remote antenna that comes with it.  I believe the Spiders are OPTO so they do not provide power, so you will need an external power source when you calibrate these.  YOu probably already know all of this...  Other than this, the other thing I would be looking at is how the Spider's have been configured.  You may need to get a programing card to see how they are configured.  You are not gonna like this.. - I removed the Spiders and went with Hobbywing 30A Platinum ESC and could not be happier.  Goodluck.


Thanks for your reply.

I did not know what OPTO meant until about 11:30 last night.

I finally figured it out.

Everything is good now.

This is why I am building my own rather than buying a RTF.

I have been in RC for 25 years, but this is my first Hex build.

Big learning curve.

Again Thanks,


Hi Guys

Also experiencing what I believe is a timing issue with motors randomly stalling mid air - see video:

heli crash (0 min 53 sec)

This isn't the first time its happened and its not always the same motor. I've got a good 50 flights in and its happened 4 times, but this is the first time I have clear video of the issue and first major failure - other times the motors have recovered near instant...

Tarot FY690S Hexacopter Frame Set
DJI Naza-M V2 Multirotor Gyro System w/ GPS
RCtimer HP4108-720KV (24N22P) Multicopter Brushless Motor
Rctimer SK-40A SimonK Firmware Multicopter Speed Controller ESC 40A
RCTIMER 2-Axis Brushless Gimbal Controller & IMU v1.0
Tarot 1355 Carbon Propellers (Two Holes / CW and CCW)

any help/ideas appreciated

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service