Simple mode issues with v2.5+

I posted this in the v2.5 release thread, but I thought this may get a bit more attention and not detract from that thread.


3DR frame, 750kv motors, APM 2.0,  v2.5.3

Since v2.5 (currently using v2.5.3),  simple mode has just not worked on my quad.  I have ruled out a mechanical or setup issue, since this exact same setup on earlier firmwares has used simple mode adequately.  Stable mode works well.  My compass is activated and declination set to the correct location.  When analyzing the logged data, the mag reading and yaw line up well enough.  So, I know my mag is working  I currently have my radio configured to have 5 modes, with four of those using the simple option.

First off,  has anyone else had this issue with v2.5+?

Secondly,  what is the SIMPLE parameter in the param file?  I noticed that on firmware editions where my simple mode worked, it was set around 40.  Now, its 61.  Adjusting this did not seem to work for a test flight last night.

Thirdly, is there a way to troubleshoot simple mode through the logs or MP?  I haven't been able to find anything as of yet.

I have not read of many people testing simple yet, but I assume it's been tested on v2.5+.  If no one else is having issues, it must be how I have my quad configured.




You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Developer

    The enabling CH7 simple mode overrides the per mode settings. If you set them per flight mode and enable CH7, you won't get Simple mode unless CH7 is high PWM output. 


  • Developer

    The SIMPLE parameter keeps track of which of your modes have SIMPLE enabled. It looks like 62 means its enabled for all except the first mode. That number is the sum of the values for each mode that it is enabled for.

    Mode 1: 1

    Mode 2: 2

    Mode 3: 4

    Mode 4: 8

    Mode 5: 16

    Mode 6: 32

    But you have also enabled the ch7 simple mode switch. I am not sure if those two setups play nice with each other. I will have to poke through the code.

  • Developer

    I noticed that you have your CH7 setup to activate simple mode. I can't see from that log file whether or not you activated simple mode via ch7 during the flight, but I do see that your mag_heading and yaw line up very well so I doubt that the mag has anything to do with your problems. It almost sounds like you weren't activating the mode at all. Do you have the tlog from this flight?

This reply was deleted.