I just started SITL for Windows using ArduPilot. I am at the Step 7 of setting up SITL using Linux. I keep getting an error " wp:command not found" whenever i use "wp load ../Tools/autotest/ArduPlane-Missions/CMAC-toff-loop.txt".

 I have already checked for the paths in .bashrc and changed them accordingly as some of the mavproxy stuff didn't get installed in the Home directory. I also ran the line endings fixes by doing the dos2unix.

So, this is the only place I am getting stuck at and don't understand why it can't find the command. Let me know if you need anymore details.

Thanks.

Views: 377

Reply to This

Replies to This Discussion

Just further information on the wiki links I followed for trying to setup the SITL.

I started with trying to setup SITL on Windows

http://dev.ardupilot.com/wiki/setting-up-sitl-on-windows/

which basically guides you to setting up a Virtual Machine with Ubuntu and installing the necessary files for SITL on Linux.

http://dev.ardupilot.com/wiki/setting-up-sitl-on-linux/

I am currently stuck at the step 7 with it not able to understand the command .

I am new to the whole UAV- Linux development environment and would appreciate any thoughts or help with regards to this.

Thanks !

Thomas,

Make sure that when you enter the wp command that the mavproxy.py script has loaded and you are entering the command "wp load..." into the mavproxy interface.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service