Hello Guys! I've encountered a problem with my Ubuntu in VMWare.... so I've been doing an altitude test for a while with SITL and have been connecting it with Mission Planner in my windows... And so far it was good... but then my SITL stopped working for some reason... I've tried updating all python stuff and nothing worked... I use this scheme on the terminal below:

export PATH=$PATH:$HOME/jsbsim/src
export PATH=$PATH:$HOME/ardupilot/Tools/autotest
export PATH=/usr/lib/ccache:$PATH
. ~/.bashrc
cd ardupilot/ArduCopter
sim_vehicle.py -w


**wait for console then press Ctrl+C

sim_vehicle.py --console --map --aircraft test
output add *IP ADRESS*:14550

**connect to mission planner using UDP


mode guided
arm throttle
takeoff 5

So far the drone arms but does not takeoff... Please help!

Views: 91

Reply to This

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service