SITL - window access error

I'm trying to get SITL running natively on my windows 7 pc, but now keep getting a "window access not found" error on the cygwin terminal

I've followed the instructions on the wiki to the letter, and had no problem in downloading and setting up cygwin and then building the codes from git hub. I'm using the Arduplane code for fixed wing.

To my surprise the simulation started with no error, and I was able to view the three console windows for the simulation with the red plane on the runway somewhere in OZ, but ever since that first time when I try to launch the simulation from the cygwin terminal using the "sim_vehicle.sh -j4 --map" command it fails and I get the windows access error message in cygwin.

I've searched the forum and have tried using git pull to update both the Ardupilot and JSBSim code, I've also tried disabling the windows and avast firewalls on my pc with no success.

I've tried using the Arducopter code too but the result is the same. 

Any help would be very appreciated. 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hi Martin, have you solved this error? I have the same problem.

    • No Daniele, still stuck at the same point.

      I have tried starting SITL directly using Mission Planner which works once and then throws up a socket error and won't start after that.

      This and my original window access error are beyond my pay grade I'm afraid.  

      • Do you have MissionPlanner for windows?

        • You can find Mission Planner here

          Sorry for the duplicate reply Jack.

        • Yes, I only use Windows as I am not really familiar with Linux,

          I'm currently using Mission Planner version 1.3.32.8

This reply was deleted.

Activity

David Hori liked Isabella Domi's profile
Wednesday
gotham liked gotham's profile
Dec 3, 2020
More…