Looking for some suggestions to try and troubleshoot an interesting problem.  I have a standard ArduCopter kit (the most recent version from the DIYDrones store, + GPS / magnetometer / sonar, but no telemetry) and am running 2.0.23.  In addition to the drift issues under discussion in another thread, I have noticed that in altitude hold and gps loiter modes, I have a great deal of difficulty with altitude.


When operating close to the ground (ie what I assume is sonar range) if I put the copter in a stable hover and then engage the elevation hold, it works pretty great, it holds through a range of about a foot or so.  Engaging alt hold higher off the ground (6'-8' altitude approximately) causes the copter to head straight up into the sky at a fairly good clip.  This is consistant and every time I've seen it I have aborted the hold and gone back to Stabilize as I don't want to lose the copter.  This same thing happens when engaging GPS loiter mode; loitering at low altitudes works well, loitering higher than about 6'-8' causes it to hold position fairly well but progressively gain altitude.


Also not clear if this is related: even at low altitudes in hold mode, it can fly around fairly well and it will hold altitude, but if I start moving at a good speed (stick far forward, copter angling ~30 degrees) it will begin a rapid ascent as described above.


I saw this with the barometer uncovered and so added a small piece of foam from headphones over the sensor hole, and it doesn't appear to change anything. 


Both the ALTITUDE and SONAR tests in the CLI give what appears to be decent data when I run them over USB, the sonar's a lot more precise but I believe that's normal.


Any thoughts?  Any other information that would help troubleshoot this?



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Also just received my sonar.

    It works veru accurate but in the planner I get 33 cm when the sonar is against the floor. Also the alt err is 33cm.

    It seemsit doesn't go below 33. Is this normal?

  • Update:  Today I removed the sonar (which, as I never specified, is an LV-MaxSonar-EZ0 from the diydrones store), disabled it in the CLI through APM Planner, and went for a flight.  Altitude Hold and GPS Loiter now work at all altitudes I tested, I could not get the copter to take off vertically the way I'd seen before, it held onto its altitude well though with more fluctuation than I saw with the sonar at low altitudes.  I would expect that to be the case.


    In alt hold mode I was even able to maneuver a bit aggressively and it sustained its alt.


    It looks to me like at least with my sonar unit, the copternever seems to pay much attention to the output from the baro.  As much as I miss my rock-solid low altitude stuff I think the sonar's going to stay disabled for now until we know more.

  • I first flew my Arducopter without sonar and baro alt hold worked pretty good, a couple days later, I installed sonar and my experience is exactly the same as yours now, sonar hold works good, but when it gets out of sonar range, it climbs until I return to stab mode. See my videos, one is baro alt hold, the other video is sonar alt hold and you can see the quad climb when it loses sonar lock.


  • 3D Robotics

    Thanks for the beta test report. Alt hold is something we're working on is being revised in 2.0.24.  It should be pretty solid at all altitudes by the time we take AC2 out of beta in a week or two.


    I assume you checked your altitude sensor readings in the CLI test menu and they looked fine. 

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21