Tried to fly 2.1.0 (Alpha as called in MP)  today. Tried Loiter , which I didnt find particularly good, but noticed that at sonar altitudes (0 to 8 meters)  something was wrong, the copter just decended. Thought I should test the sonar in Mission Planner but in 1.1.9 I cant get into terminal mode, even with the flight switch in correct position . And the "click 3xCR" does not work either.

So I tested in Arduino, and all i got was 21 cm, no matter where I pointed the sonar.

So downloaded 1.049 source. The Terminal in MP works there so tried the sonar test, and lo and behold the sonar showed correct values.

This is one step ahead and three back. I am just trying to get to something stable and working here, but it seems every change brings more problems than it solves.....

(BTW, I also habe seen others in the forum with same sonar trouble after 2.1 upgrade so seems to be a general problem)

Views: 419

Reply to This

Replies to This Discussion

As mentioned, you have to hit "enter" three times to get into CLI mode. Make sure to click in the Terminal window first so the keyboard focus shifts to that. 

Which sonar are you using?

Focusing the window was the problem, the Terminal works, and after downloading 2.1.0 from MP the sonar seems to work again. Tested with arduino as well and sonar works....   Strange the sonar did not work in loiter then, will try again.

Thanks for the help,


Sonar does not work in cold weather. The sensors can't handle the low temps. I just tried it with the latest code and it works just the same.


I also upgraded and cannot get into the CLI.  When I am in terminal mode random characters jump on to the screen and then I hit enter 3 times.  At that point between the junk I can see the magnometes initialize.  Then it stops working.

I must be doing something wrong??  Help.  I can fly it, but cannot test anything.


Flick the cli switch to rails side? I haven't tried in new code but old this was the case.

I think that this was required in the old version.  I tried it and it does not matter.  The new version is supposed to go into CLI on three ENTER's.  This is the part that does not work now.  Any help is appreciated.



Make sure you click in the terminal window to shift the keyword focus to that.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service