i've been having on-going issues with my sonar and wonder whether anyone can help?

i've used the terminal sonar test and with the sonar connected i get a continuous 20cm reading, no matter what and without it connected i'm getting 700cm.

i was concerned that the sonar was faulty so bought another which arrived today. just tested that and i'm getting exactly the same readings.

just updated to latest version of the code and been through the config - enabling the sonar etc

tested the votage from the oilpan connection to the sonar it's reading nothing - i was expecting to see 5v - pins are soldered correctly.

any ideas?

Views: 287

Reply to This

Replies to This Discussion

Actually same problem here. Uploaded some recent code and always get that 20cm reading. Was also suspecting a faulty sonar as I haven't used the quad over the rainy season. I better double check then whats going on.

for some reason i wasn't getting 5v from that pitot connection. i noticed the 5v on one of the unused extensions so soldered on some pins, took 5v from there and hey presto its's working.

so problem solved until the v2 board arrives, but still not clear why the 'proper' 5v pins are on the wonk.

The apm board have very thin wiring print to this 5v pin, try to follow the wiring print from the pin and towards the middle of the board. Try to measur 5v from print wiring, if you meaur 5v solder a wiring from there to 5v pin

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service