strange behaviour of pixhawk-request help to understand

Hi

I am building a 1300mm octocopter with 30AH lipo. I want to be using a tegra tx1 for onboard visual processing coming from a sony a6000. 

I have built the drone and assembled it. I have configured it as usual. I was using the external compass on the m8n gps. and when the compass calibration happened both of them had similar reading all under 150. I have also done a compass motor calibration for the offset.

however when I took it to the field and wanted to test it in autonomous mode, it started behaving weirdly. below is the auto diagnosis of the data log and also please find attached the flight log.

I fail to understand what could have gone wrong. I would appreciate any help solving it. I wish to fly the machine and then work the tegra part.

Size (kb) 856.1298828125
No of lines 10433
Duration 0:00:28
Vehicletype ArduCopter
Firmware Version V3.5.3
Firmware Hash 1a85c237
Hardware Type
Free Mem 0
Skipped Lines 0
Test: Autotune = UNKNOWN - No ATUN log data
Test: Brownout = GOOD -
Test: Compass = FAIL - Large change in mag_field (257.75%)
Max mag field length (1112.76) > recommended (550.00)

Test: Dupe Log Data = GOOD -
Test: Empty = GOOD -
Test: Event/Failsafe = FAIL - ERRs found: CRASH GPS_GLITCH
Test: GPS = UNKNOWN - join() takes exactly one argument (2 given)
Test: IMU Mismatch = WARN - Check vibration or accelerometer calibration. (Mismatch: 0.81, WARN: 0.75, FAIL: 1.50)
Test: Motor Balance = FAIL - Motor channel averages = [1722, 1684, 1360, 1314, 1480, 1441, 1754, 1650]
Average motor output = 1550
Difference between min and max motor averages = 440
Test: NaNs = GOOD -
Test: OpticalFlow = FAIL - FAIL: no optical flow data

Test: Parameters = FAIL - 'THR_MIN' not found
Test: PM = GOOD -
Test: Pitch/Roll = UNKNOWN - 'BarAlt'
Test: Thrust = GOOD -
Test: VCC = WARN - VCC min/max diff 0.563965v, should be <0.3v

thanks in advance 

2017-12-22 11-18-53.bin.jpg

2017-12-22 11-18-53.kmz

2017-12-22 11-18-53.bin

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Activity

DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Test my car. RTK GPS worked great. Thanks @emlid for their support. https://t.co/EkQ6qmjmWR
May 8
DIY Drones via Twitter
RT @chr1sa: @kane That's @diydrones circa 2009. Still have a box of those Canon cameras that we used to strap into planes, just like this.…
May 3
More…