Hi-

Hoping someone out there can help me with an issue with the Tarot 2-axis gimbal.  I hooked it up out of the box (didn't buy it from 3DR), plugged it in, and it worked perfectly.  Leveled immediately, tracked pitch and roll perfect.  No problems.  Then I decided to hook it into my pixhawk to control the tilt with the tuning knob on my Futaba T8J.  That's when things got complicated.  I made a custom wire harness to hook the pins on the gimbal (per instructions on ArduCopter website).  Then I tried updating the gimbal board.  I am running Windows 8 on Parallels on my Mac.  Followed all the instructions on the APM site.  All looked good, the parameters matched the picture on the website, it said it was running 1.5 firmware in the lower left corner of the gimbal setup program.  Then i tried to set up tilt on APM Planner.  I couldn't switch tilt to any of the RC input pins.  You can drop down the menu, try to select RC9, and it just goes back to DISABLED.  Can't do anything.  So I say why not shut everything down and restart.  Pulled the battery, disconnected Mavlink/Gimbal USB cables.   Plugged it all back in again and now the gimbal tries to swing around backward when it starts up.  Doesn't level off at all anymore.  It's all screwed up.  This all started after updating to Tarot firmware 1.5.  Any ideas of what could be wrong here?  Short of buying a new controller board, I'm stumped.

Thanks!

Views: 227

Reply to This

Replies to This Discussion

Update... now when i plug my Tarot board in, all i get is three quick yellow/green light flashes.  Then nothing.  No movement, no nothing.  Does this sound like a bad board?  Should i start from scratch?

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service