Telemetry - OpenLRS and APM


I have been trying to get telemetry to work with my OpenLRS RX and TX. Been trying out different setups and baud rates but not got it to work.


The transparent serial bridge is working perfectly but when I try to connect the RX to the APM Telemetry port (port 3) I cannot connect via Mission Control. Running a serial monitor I can see traffic - ascii in the beginning saying something like "<startup_mode: ground>" and then binary. Seems to be ok... but not good enough to connect.


I think the problem might be related to bandwidth. OpenLRS supports 750 byte/seconds from the RX to TX. After looking at the documentation and source code I have not figured out how much data MAVLink protocol is configured to send per second.

Does anybody know?



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Just to clarify:

    The MinimOSD extra firmware that you get from my website has the baudrate set to 19200. To use that you need to set the SERIAL1_BAUD to 19 on mission planner and set the other sr0 and sr1 parameters as recommended in minimosd extra wiki. If you are using latest Mission Planner (version 1.3.2 i think) than you have to uninstall it, and download an older version (download here 1.3.16). The latest version doesn't save the sr0 parameters (it's a feature). You also need to set the handset to 19200. After you do all this (like described in the website) you should normally get telemetry displayed on the fpv screen through MinimOSD and on the 9xr screen as well. You should also be able to connect to Mission Planner on your PC using a bluetooth module or FTDI cable. Does the rest work for you except for the MinimOSD. I don't think the APM Micro matters, they use the same firmware even though i don't have one.

    • Since I was not able to modify the SR0 parameters in mission planner (despite downgrading), I tried editing them from the Tower app via the bluetooth/openlrs connection:

      - I can upload the changed parameters and when downloading them again they are fine. However, I still have no mavlink data on the osd.

      - When I restart the apm the SR0 parameters are reset to the previous values.....still no mavlink data.

      This is super weird. Any clues?

      • I suggest:

        - Download Arduino IDE (if you don't have it)

        - Download EEPROM Clear and flash to your APM (don't forget to choose Board: 2560 and the right com port)

        - Install APM firmware from the beginning and try again.

        Before you do all the changes above, you could try to set everything to 57600 and see if it works.

        - Download and flash OpenLRSng - Glitsy TX/RX @57600 like described here and configure them with putty

        - Download and flash MinimOSD extra @57600

        - Change Handset baudrate to 57600

        - On APM Planner set SERIAL1_BAUD to 57 and write parameters. Reload and see if it works

    • To clarify what is already working:

      Telemetry via openlrs to the handset (but I am not using modified handset firmware). From the handset it goes to a bluetooth module and from there to PC/mission planner or tablet. This works fine and is on the same cables as the OSD would be.

      Regarding your solution tips:

      I had not downgraded mission planner. Now I uninstalled it and installed v1.3.16. I realized that the sr0 parameters were not taken over. Sr1 looks fine. Picture below. When I change the sr0 values and click on write I get an error: "Set <parameter name> failed." Looks like for some reason I am not able to change the parameters. After I did that I also have to restart the apm to read the parameters at all... Could this be a fault, because I am connected via usb and at the same time changing the usb/serial connection parameters?


  • Hi!

    Thanks for the great instructions. Unfortunately, it doesn't seem to work for me. I used the 9600 setup and seem to get data transmitted, but Mission Planner always times out. The data in the terminal of Mission Planner looks like this:


    Can anyone help?

    Also, there are 2 things that I was not able to follow in the instructions:

    - Wiring the DTR-Connection to the RX. Where is the APMs DTR pin? It's not on the telemetry port (only 4 pins)

    - Disable FrSky emulation: I don't seem to have that option. I chose Telemetry:Yes. Where is this option?


  • You can check a step by step guide on my website.


    1. What do we get?
    2. OrangeRX Open LRS Transmitter 1W (JR)
    3. OrangeRX Open LRS 433 9CH Receiver
    4. What you need
    5. Turnigy 9XR mod
    6. Flashing Turnigy 9XR with OpenTX firmware
    7. OrangeRX Open LRS Transmitter Mod
    8. Flashing  TX/RX (OpenLrsng - Glitsy branche)
    9. Configuring TX/RX using Putty
    10. Connecting to Mission Planner through FTDI
    11. MinimOSD
    12. Bluetooth
    13. NFC Tags
    14. Connecting to Tower
    15. Antenna


    • Website changed to:


      • Why do your pages keep jumping back to the top every 5 secs or so?  It makes it very hard for me to read them at all.

        • I just checked the site from my PC, there is no such a problem. If you are browsing from a smartphone maybe you are clicking the "scroll up" button accidentally. If you are having the problem from PC please let me know what browser are you using. I am using chrome and there is no problem. 

      • Hi!

        Thank you very much for the great instructions. I was finally able to get telemetry via openlrs and BT working. However, my OSD is no longer working. I used your firmware with 19200bps and it's still not working. Actually it is just feeding the video through, no overlay whatsoever.

        Any tips/ideas?


This reply was deleted.