I will resume my problem and the solution:

My board is 2.5.2 (not original) and with firmware 2.9 works fine (or it appears to be but it is in danger).

After trying to update firmware from 2.9 to 3.0 or 3.0.1 the problem is the bad gyro health caused because of 5V on 3.3 regulator.

I am engineer so I unsold the 3.3 regulator and checked it. It was ok, but the 3.3v rail is at 5v, even without regulator soldered

Then I tried to replace the regulator for another one, same problem...

I tried to downgrade to firmware 2.9, the board works OK, so I tried to fly and it flies ok (or it apears to be OK, but all the sensors are overvoltage).

After 30-40 mins fly time the quad started to do some suddenly movements (I dont knew whats happening then, now I know it was the sensors at 5V instead of 3.3...)

But now I understand everything:

There is a problem in the board layout, there are a level shifter from 5V of the ATMEGA to 3.3v of the flash memory.  The 3.3 and 5v references are inverted. Thats all the problem, nothing from regulators.

SOLUTION: Very hard and complex soldering skills. You must cut wires from the dataflash level shifter and interchange 3.3 and 5v. Cut the blue lines and replace with cable the red lines.

OR maybe you are not interested in use the dataflash but you want to repair your board: It is only necessary to cut the 2 wires in blue and the board will work perfect but the dataflash will appear as disconected.

It is incredible that all the sensors worked at 5v for so long time ago and didn't crashed :o. Also, the dataflash is working at 5V without problems... Incredible!!!

I didnt try to fly yet but the board loads the 3.0.2 firmware properly and passes all the tests.

3691101097?profile=original

EDITED LATER: 

Mine is working with this change but the problem was the data lines and not the power lines of the level translator. You can check it in the datasheet of the chip.

So if you want to solve this the first thing you have to checkout it is if your pcb has the bad level routing on the dataflash. Definitive solution is very complex to routing but like me you can repair it. 

Thanks everyone. 

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

      • Developer
        According to the data sheet of the shifter, it's not within spec, but there have been Zero cases of failure of the level shifter reported.
        If it failed, it could stop logging, but not flight.
  • Developer

    unfortunately this is not solved. Please all, DO NOT TRY THIS SOLUTION YET.

    We ARE investigating this very issue at the moment, and will inform you of any findings.  There IS an issue with the shifter, but it is the Data lines that are wrong not the Vcc lines

    the 3.3v VCC is rated to MAX 4.5v, so connecting this to the VCC 5v as suggested here could lead to an unknown situation.

    Please wait for some results from our testing first.

    Please note, the Data-flash is 5v capable, but not reccomended.  we have NO evidence of Dataflash failing due to this.

    • http://www.rcgroups.com/forums/showpost.php?p=27655371&postcoun...

      RC Groups
      RC Groups - the most active Radio Control model community: electric and fuel rc airplanes,rc helis,rc boats and rc cars. Features discussion forums,…
      • 3702641718?profile=originalThis means that Logic Level Converter chip is not needed at all!!!

        Can someone official answer on this please?

        Quote:
        Originally Posted by jabram View Post
        You are not anywhere near as confused as some.

        Apparently they designed in a level converted when one is NOT REQUIRED then they wired the data lines on the level converter backwards, they did correctly wire the power supplies.

        Anyway as we already know it appears to work, no, it is not a miracle.

        Evidently it works because all the inputs of both types of dataflash used on APM 2.5.x are 5V Tolerant

        Again, someone did not read the relevant data sheets.
  • Something doesn't make sense here.  Why don't 100% of the boards exhibit the problem 100% of the time?

  • Very intersting...but how does it come that people report that they could revitalize their boards by exchanging the reg ?

    Here is a huge thread on a german forum, maybe google translate helps out http://fpv-community.de/showthread.php?37502-APM-2-52-eine-tickende...

    And somehow it sounded like you got the issue after the firmware update and before it was fine ?

    Best Regards
This reply was deleted.

Activity

David Hori liked Isabella Domi's profile
Jan 12
More…