Thermopile Setup Gone Bad?

Just wanted to see if anyone out there had a ArduPilot/thermopile setup go bad?  Mine was working fine and had about a dozen successful flights under its belt.  No crash landings or anything severe happening to the plane.  The next flight on startup the servos all begin to jitter and act funny.  Moving the orientation of the plane sometimes helps but doesn't fix the problem.  I was able to fly it a few more times like this but it seemed to get worse and now the Thermopile setup is nonfunctional.  Everytime it starts up, after its initial startup, the servos go crazy and nothing seems to help/fix it.  I've replaced and moved wire positions, I've replaced both the ArduPilot board and the airspeed sensor, I've tried different receivers to no avail.  Could this be caused by broken/damaged thermopile sensors?  Has anyone experienced something similiar to this?


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Developer
    Can you load some other code such as the sensor tester? Do you get smooth IR reads? Do the servos twitch?
  • Developer
    You have a bad connection in the connector or wire...
  • My ardupilot setup has similar issues though I have been running a UDB for awhile now since my issues with my servo twitching has yet to be sorted out.

    Though mine did this from the very beginning but your issues sound identical to what is happening to my ardu setup. Wish I could offer a solution as I would like to actually get my ardu to fly.

    I also have tried all you have as well and a few others tweaks

    So as to get others to help more you may want to post all the info you can about your setup like radio and frequencies and post of a video of the twitching. Just my 2cents.
This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21