Traditional Heli - Pixhawk Motor Interlock enabled

Hey guys, I think this maybe a common issue here but I have everthing setup with my radio (taranis) and modes all set with the 6 pos switch all good, just cannot get the this "motor interlock enable" message to disapear or even arm the unit. I have googled but cannot find a way to set this up correctly.

I am running latest mission planner, and latest firmware for traditional helicopter.

does anyone know how to set this function up or even know if I need it?

Cheers

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Hey Rob,

    thanks for the response!, Im keen to know more about this "kill switch" as Im confused on how to set this up? or infact what it is?, am I right to assume here that its just a switch to kill all power to the heli? (my throttle is on channel 8 as well btw).

    also how do you find version 3.4 as Im running the same an was keen to here your throughts? is it better than 3.3?

    cheers!

  • This might be a little late but I had the same issue the other day. Make sure your collective pitch and throttle are in their minimum position. This happene when I upgraded to Arducopter 3.4. I'm using a gas powered helicopter so my throttle is on channel 8 and a good idle is about 1170us. In order to remove the interlock enable message I have to turn the engine kill switch on my remote  that has an output of 982us. I just hold the engine kill switch and arm the helicopter and the message goes away.

This reply was deleted.

Activity

sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24
More…