Tricopter spin.

I've built a Tricopter. The radio is calibrated in Mission Planner, the Esc's are calibrated. Prop configuration, right prop, (Pusher) ran clockwise, the left prop and tail prop (Regular) turned counter clockwise. No luck? I tried all different prop configurations nothing worked? Anybody have any ideas what is causing the Tricopter to spin?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

                  • The APM may not be bad after all? (The radio wasn't programmed correctly.) I'll know in a while if I got this right?

            • To many hours trying spent to configure this APM. Every has been rebuilt and recalibrated several times, all indications are that the radio, Esc's, Compass, GPS are calibrated and functioning. "But the Tricopter simply will not fly?"

              So! Is there anyone using a FS_TH9X Transmitter, with a 2.6 Arducopter APM?

              Would like to know what exact settings you are using on your transmitter, and APM?

              If I input those on my transmitter and APM, and the Tricopter still doesn't respond, then I'll know its a bad board...

              • Hi Joe,

                if you connect to MP and go to Initial Setup-->Mandatory Hardware-->Failsafe you can see on the green input bars if APM is getting signal from your RX and on the output bar the reaction of the APM to it.

                If your FS_TH9X is using the same channels as Futaba its fine, otherwise you can either change the output channels on your RC system or simply connect the aileron output of your RX to the aileron input of APM and so on.

                • Hi Ultrafuge,

                  Yes when I go into MP - Mandatory Hardware - Failsafe. The only bars that move are: Radio IN, Radio 2, Radio 3.  Radio 4,5,6,7,8, those bars don't do anything, no matter what stick or switches I push. And next to them Servo/Motor OUT Radio,1,2,3,4 don't do anything either?

      •  Hi Joe,

        Ok that sound promising, that compass calibration takes a while but shouldnt be causing the issues you've had.  Sounds like it's picking up the boards orientation correctly.

        So when you flick the mode switch on the radio, do you see a corresponding change in the Radio Calibration screen?  It should change it's PWM value.  If not check that the input to ch 5 is whatever you radio switch is outputting?  I'm guessing you are using a mixer to get 6 modes, make sure it's plugged into the channel that the radio is sending the mix to.


        When in the flights mode screen in MP, what happens when you try to change modes, does it display a change there?  Does the PWM value change here (if it did change in the Radio Calibration screen it should change here too).

        You can do the test without the props (safer that way too, good practice to get into), to see if you get any change in the motors output as you tilt it or apply throttle and aileron / elevator and yaw.  If it still doesn't work then I think you may have to try a different board to rule it out.

        I had forgotten about the reset, you can reset it with the reset button too.

        I agree that it is highly unlikely to be a firmware bug in this case.

        Chris

        • Hi Chris,

          In MP - Flight Modes - Flight Mode 3 is Highlighted Green - (Stabilized). Flight Mode 1 is Highlighted, Dark Blue - (Stabilized). In fact Modes 1-6 are all listed Stabilized, which is the default setting.

          Then in MP/Flight Mode, when trying to change modes nothing happens? Radio shows Mode: Stabilized - Current PWM 5:1469. Radio screen reads; "FM-PPM - MODE 5" The PWM value doesn't change when toggling the switch?

          Joe...

  • Hi Chris,

    I just "reset" the APM using the DOS commands in "Terminal" in Mission Planner. And I was able to do the "Compass Calibration."  Also the Horizon moves when I pick up the Tricopter. GPS 3d fix. Clocks ticking away, numbers are fluctuating, radio calibrated, and so are the ESC's. I'm charging the battery and when its charged I'll try again and see if the APM is working properly?

    As for the radio it doesn't show any outputs. Just what mode its in, battery, time and type of  craft. I hope its not a dud board? But if it is? I'll have to get a replacement...

  • Your tail servo should be plugged into output 7. When in stabilise mode, it should move left-right when giving jaw on the controller. (Don't go in the air until servo works). You may need to reverse the channel 7 as per instructions above
    • It's plugged into output 7. And its in stabilized mode. But no response? Just throttles up, and throttles down? Trying to use Motor Test in Mission Planner. Select "Test Motor A or B or C". And message comes up - "Command denied by Autopilot?"

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @knightsautoteam: Hi @diyrobocars, we are Orlando's first Autonomous racing club and would love your support. We are hosting our first K…
Jan 20
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #14 - #ParkingLotNerds join us January 15th for #AutonomousRacing #RoboRace ⁦@DAVGtec…
Jan 16
DIY Robocars via Twitter
RT @chr1sa: And after that came our races, 50 in all. This battle between these two Russians was the best we've ever seen -- incredible fig…
Jan 16
DIY Robocars via Twitter
RT @chr1sa: Before our @DIYRobocars virtual race this weekend, we had a presentation from the team that won the Indy Autonomous Challenge i…
Jan 16
DIY Drones via Twitter
Dec 12, 2021
DIY Robocars via Twitter
Dec 12, 2021
DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Dec 4, 2021
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25, 2021
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23, 2021
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23, 2021
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20, 2021
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20, 2021
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9, 2021
More…