I've built a Tricopter. The radio is calibrated in Mission Planner, the Esc's are calibrated. Prop configuration, right prop, (Pusher) ran clockwise, the left prop and tail prop (Regular) turned counter clockwise. No luck? I tried all different prop configurations nothing worked? Anybody have any ideas what is causing the Tricopter to spin?

Views: 4271

Reply to This

Replies to This Discussion

Lets hope the cloners are on team.

Hi Joe, just set up my tri as well had a similar problem then I had to reverse the "ch7" setting in mission planner (as opposed to the radio) in the advanced parameter tab. Visually, yawing right (left stick ->right) on the controller should rotate the pusher tail counter clockwise when viewing the tail from the outside looking center. 

Hi Brandon,

I went into the advanced parameter tab and changed it from Channel 4, (Yaw Channel), to Channel 7. I went through the entire APM calibration again. Everything checked out...

But I haven't hooked the battery by itself yet to see if the Tricopter is going to fly? I'll put the props back on tomorrow and see what happens? I'll post the results. Thanks for the input...


 Hi Joe,

Ok that sound promising, that compass calibration takes a while but shouldnt be causing the issues you've had.  Sounds like it's picking up the boards orientation correctly.

So when you flick the mode switch on the radio, do you see a corresponding change in the Radio Calibration screen?  It should change it's PWM value.  If not check that the input to ch 5 is whatever you radio switch is outputting?  I'm guessing you are using a mixer to get 6 modes, make sure it's plugged into the channel that the radio is sending the mix to.

When in the flights mode screen in MP, what happens when you try to change modes, does it display a change there?  Does the PWM value change here (if it did change in the Radio Calibration screen it should change here too).

You can do the test without the props (safer that way too, good practice to get into), to see if you get any change in the motors output as you tilt it or apply throttle and aileron / elevator and yaw.  If it still doesn't work then I think you may have to try a different board to rule it out.

I had forgotten about the reset, you can reset it with the reset button too.

I agree that it is highly unlikely to be a firmware bug in this case.


Hi Joe,

why do have 8 inputs ?

Did you try (without props!) in MP-->Initial Setup-->Mandatory Hardware-->Failsafe if your TX commands work ?

Does a roll, pitch, yaw input move the correct bar and a mode change display the correct mode ? If yes, and the motor speed doesn't change according to the bar try with a servo to check for an ESC problem.

Hi Ultrafuge,

Why do I have 8 inputs? I was tracing the signal from the radio to the receiver. I wasn't sure what pin was doing what? So I hooked them all up and see which pin responded to the signal sent from the radio. I only have 1 through 5 hooked up now on the Input side. 1,2,4,7 on the Output side. As for the Roll, Pitch, Yaw input I haven't tested that yet?

MP without props? Not yet. I had "erased" the APM, and then step by step went and recalibrated it. MP-Installed Firmware-Wizard-Mandatory-Hardware. Right now Flight Mode 1 through 6 are listed Stabilized. Flight mode 3 is Highlighted Green.


Toggling the Flight Mode switch on the radio doesn't change the Mode's showing in MP? 

Hi Chris,

In MP - Flight Modes - Flight Mode 3 is Highlighted Green - (Stabilized). Flight Mode 1 is Highlighted, Dark Blue - (Stabilized). In fact Modes 1-6 are all listed Stabilized, which is the default setting.

Then in MP/Flight Mode, when trying to change modes nothing happens? Radio shows Mode: Stabilized - Current PWM 5:1469. Radio screen reads; "FM-PPM - MODE 5" The PWM value doesn't change when toggling the switch?


To many hours trying spent to configure this APM. Every has been rebuilt and recalibrated several times, all indications are that the radio, Esc's, Compass, GPS are calibrated and functioning. "But the Tricopter simply will not fly?"

So! Is there anyone using a FS_TH9X Transmitter, with a 2.6 Arducopter APM?

Would like to know what exact settings you are using on your transmitter, and APM?

If I input those on my transmitter and APM, and the Tricopter still doesn't respond, then I'll know its a bad board...

Hi Joe,

maybe I totally misunderstand you, but you say:

'Right now Flight Mode 1 through 6 are listed Stabilized.'

If all Flight modes are set to Stabilized, why should there be a change :

"Toggling the Flight Mode switch on the radio doesn't change the Mode's showing in MP"

YOU are supposed to change the Flight Modes in MP, so that you can select one with your TX switch. You can see this by connecting to MP, i.e. at MP-->Initial Setup-->Mandatory Hardware-->Failsafe

Hi Joe,

if you connect to MP and go to Initial Setup-->Mandatory Hardware-->Failsafe you can see on the green input bars if APM is getting signal from your RX and on the output bar the reaction of the APM to it.

If your FS_TH9X is using the same channels as Futaba its fine, otherwise you can either change the output channels on your RC system or simply connect the aileron output of your RX to the aileron input of APM and so on.

Hi Ultrafuge,

Yes when I go into MP - Mandatory Hardware - Failsafe. The only bars that move are: Radio IN, Radio 2, Radio 3.  Radio 4,5,6,7,8, those bars don't do anything, no matter what stick or switches I push. And next to them Servo/Motor OUT Radio,1,2,3,4 don't do anything either?

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service