Does anyone know wtf is up with this 'uBlox 6M GPS Module V2' that i just got from RTFquads? I just set this board up and i am trying to get this all going but for some reason it isn't being seen by the APM. I tried to upload the GPS passthru to the APM following Randy's youtube video but i couldn't get that to see it either?

Anyone know what these sequence of light are?

Really want to get this quad in the air asap but this seems to be what is stopping me. When i connect all i get is 'NO GPS'....

Any help is totally appreciated. THANKS!!

this is the gps:

Views: 2673

Replies to This Discussion

'No GPS' in MP just means it can't get a satellite lock -- you may need to find a higher floor or head outside.

APM board LED explanation is here.

you mean 'no fix'??!!!  this says 'No GPS'

Right.  My bad.

The GPS is brand new... and i have not changed a thing. Just plugged it in...such a bummer as i have been waiting for parts from everywhere building this quad and everything is ready go ...execpt this little bugger. Someone must know the fix for this!

Yeah, that has to suck.  Any chance your 3.3v regulator may be bad?

The test is here.

Hey Crady,

I would love to test that but i am not getting the symptoms that Randy is displaying... Everything works just fine and dandy except the GPS. What i am thinking is that the GPS aint comfigured correctly, but i tried doing the GPS passthru (loaded the firmware) and then loaded up uBlox center but could not get it to see the gps. Maybe the GPS is bad... but why is it blinking...

just bums me as this quad is so ready to fly otherwise.

Sorry, man.  It does sound like the GPS module is bad.  But while you're getting it sorted you should still be able to fly -- you'd just be missing out on any GPS-centric features.


The uBlox needs to communicate with the APM at 38,400 baud. The default baud rate is 9,600. Also, the APM is expecting to see the uBlox GPS configured with the custom 3DR firmware found here: Config File

Are you sure that you have the tx and rx lines connected correctly from the GPS to the AMP?


TCIII ArduRover2 Developer

There site says its setup for multiwii and since its not from 3DR who know's.  

Have to ask, but have you been outside for the link test. Only asking cause the video looks like it was shot indoors. I have had the same problem and it was when I was inside  and hooked to APM.


During a GPS warm start I can get a minimum of 5 sats indoors and after 10 minutes I can usually get 7 - 8 with a uBlox LEA-6H.


TCIII ArduRover2 Developer

The incorrect baud rate would explain the problems including the inability to use the GPS pass-through.  If you're comfortable compiling the gps pass through sketch yourself with arduino you could replace the 38400 with 115200 in these two lines of the sketch.


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service