I have an APM with 2540 IC running APM 2.12 in a skywalker with Hitec Auroa 9 RC. The hardware is extremely unstable, APM is very frequently losing all configuration, about every 3rd flight. I have to resetup each time.

Now I am trying to fly Auto mode (which I have done many times previously), but whenever I select either AUTO or RTL the APM goes to loiter mode for both settings. When I check it on the ground in both 'show settings' and 'test:modeselect" it shows normal (and I don't even have a loiter mode set up as an option.)

I have airspeed and magnetometer and xbee installed, but even when I remove any of these componenets, I have the unstable situation of having to reconfigure APM about every 3rd flight.

When in show settings mode, the CLI reports CCC… at the mode, see screenshots:

I have reset the board and reconfigured numerous times, but it never becomes stable and the loiter mode has not recently gone away.

I have been using mission planner for all setups, but going back in to set modes in CLI. This approach does not use the reset button, ( only erase?) Is powering down/disconnecting power an adequate sub for pressing reset? ( have also tried using the reset button but that did not help).

 

 

LoiterCCC.jpg

LoiterCCC2.jpg

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I replaced the arduino board, oil pan, and airspeed sensor with another set (that I had available) and so far so good, but I have not tested extensively. Even if this does solve the problem, if anyone has ideas on why the other board would have instability problems please offer suggestions. Soldering? Something else?
This reply was deleted.

Activity

Liam left a comment on Agricultural UAVs
"Hi
I'm Liam from T-MOTOR. I would like to reach out to see if there is any possibility for us to work together.
We are a propulsion system manufacturer who offers motors, propellers and ESCs for all kinds of drone applications which vary from secur…"
Jun 30
Richard Cox left a comment on Australia
"Anyone in the DIYDRONES Australian subgroup based in Alice Springs, NT?
I am experimenting with Ardupilot (standard Arduplane), Pixhawk 4 FC in a 4-ch
RC "AXN Floater Jet" foamy plane..."
Jun 29
Omar Sykes left a comment on Australia
"Hi everyone, I am looking for someone who is good at drone building, repair and software in Adelaide. Please give me a call on 0477 319 219."
Jun 29
More…