Replies

  • Hi everybody,

    I've a MikroKopter Quadro XL quadrotor with a + configuration, a PDB QuadroKopter XL with four Bl-ctrl 2.0 connected with an I2C splitter to my Pixhawk ( the splitter is connected with the external compass and the I2C BUS of the MK PDB). I'm currently running APM 3.4.5 Quad firmware and I can arm the autopilot, so everything since here is OK.

    I've read that the mkblctrl driver support is guarantee after the Arducopter 3.2 firmware, so since Arducopter 3.2 firmware doesn't allow to have two MAG installed, I've done the sensor calibration with APM 3.4.5 Quad, then I disabled the secondary MAG; After this, I switched off the Pixhawk, put the mkblctrl_+ file in the APM folder and I've upload the Arducopter 3.2 firmware. With the LiPo battery attached, suddenly the motors start to spin (with no possibility of control them on my RC transmitter). After three times that I connect and disconnect the battery, I cannot connect via Mavlink no more with the Mission Planner, because, with the mkblctrl_+ file, the Pixhawk cannot boot (B/E yellow light is solid).

    Probably I am missing something.

    Looking at the Mikrokopter official page https://pixhawk.org/firmware/apps/mkblctrl, we have to specify the motor address order... How do I have to specify them? 

    If someone can help me, it's really appreciated :)

    Alessandro

  • Hi Marco,

    thank you very much for this information. I was getting crazy trying to solve the problem. So I have to wait for the 3.2 reléase... hopefully this will be son.

    Vielen Dank für alles und bis bald...

    Frank

  • Arducopter V3.1.5

    FW Ver: 120

    • Hi Frank,

      support for the mikrokopter escs is in current master and upcoming 3.2 Version.
      Your version did not have the support for these escs on pixhawk included.

      Cheers
      -Marco
      • Hi Marco,

        We are facing the same problem as Frank. 

        We are new to 3DR Pixhawk. We are great fans of Mikrokopter. So far we have been using all the Mikropkopter electronics (Flight Control, Navi, GPS, ESC..) but we never really achieved the precision of Pixhawk especially in position hold. We are now falling in love with 3DR Pixhawk because of its capabilities with what we have seen on YouTube videos.

        However we are trying to configure the Mikrokopter ESCs with the New Pixhawk (Px4FMU+PX4IO). The mission has been unsuccessful!

        We have tried everything that you have suggested. We tried adding the mkblctrl_x file (Without file extension) and the config.txt file into the APM folder of SD card

        1. With version 3.1.5 the ESCs are not recognized and the Green+Red LED is on all the time. We are able to access Mission Planner

        2. We tried the Beta v3.2, All the Motors Spin + able to access mission planner. But not able to arm the kopter.

        We are not sure if the latest Pixhawk (Px4FMU+Px4IO) supports the Mikrokopter ESC via i2c.

        Marco, you are the only person who is sharing positive response regarding MK ESCs with Pixhawk. (Not sure if you are using FMU and IO boards separately)

        Please let us know the secret of your success! How do we go about with the New Pixhawk (Px4FMU+PX4IO) Will the Beta v3.2 help us? Any ides when we can have the v3.2 stable version that support MK ESCs.

        Regards,

        Vinskopter

        • Hi,

          you should use 3.2 beta to use them.

          What kind of Frame are you using (X or Cross) ?
          How are the ESC's addressed ?
          Did they match the black numbering order or the red numbering order : http://pixhawk.org/_media/dev/apps/layout.png ?
          What LED(s) lit on the BL-Ctrl ESC's ? red, green or both ?

          You say that with 3.2 the Motors are Spin and you can connect to Mission Planner but not able to arm Copter.
          What does Mission Planner say when you try to arm the copter ?
          Are all your Sensors calibrated (Mag, ACC etc.) ? APM Copter have a Arming Check, and wont let you arm, if one of
          these Checks did not pass. You can override this in the Configuration with Mission Planner, but i do not recommend this !
          For arming you have to press arming Switch for at least one second, and then you can start motors with your r/c stick command.

          - Marco

          • Hi Marco, 

            Thanks for the quick reply. We tried checking all the options one by one like you suggested. With your expert guidance we finally got the Copter to work with the PIXHAWK and the Mikrokopter ESCs!!! 

            But we are facing a new problem. BAD GYRO HEALTH.

            We did not do anything much. just downgraded the firmware and upgraded again and after some time the error message is not showing. The Copter is flying all well (without any errors now).

            When I went through some of the Forums, it is really scary. Some people say that it is because of a Brown-out 3.3v regulator. There are some forums that show how to replace the regulator. But none of them are referring to the new PIXHAWK (Px4FMU+PX4IO).

            1. How do we test the 3.3v regulated voltage in the New PIXHAWK?

            2. How do we ensure that the Gyros are OK?

            3. Now that the error message is not showing, can we ignore the error and fly the Copter with full confidence ensuring that Gyros would not die when flying in mid air?

            4. If the Regulator is Brown-Out... how do we get it fixed. PIXHAWK is full of micro components. how do we know which one is the 3.3v regulator?

            Please suggest.

            Regards,

            Vinskopter

  • Hi Frank,

    which version of AC do you have on your copter ?

    Cheers
    -Marco
  • I forgot to mention:

    I checked the I2C lines with an oscilloscope. SCL & SDA on each MK-ESC are highly active.

    Are my connections right?: SDA of ESC goes to SDA on the Pixhawk, SCL and GND respectively. +5V is NOT connected. ESC's powerd by 4s battery.

    Frank

  • Hi Marco,

    thank you for the reply. I did everything as you told me to do:

    - Pixhawk is set up, all sensors and radio input are calibrated.

    - On the SD card I put a file mkblctrl_x in the APM folder.

    - MK-ESC's share I2C port with magnetometer and mag is still working fine (so no I2C collision)

    - When powering ESC's all motors beep the typical MK melody

    But,

    - Red LED's on the ESC's do NOT turn off

    - When trying to call mkblctrl -t from the nsh shell I get message: "mkblctr: command not found"

    What am I doing wrong?

    Regards,

    Frank

This reply was deleted.

Activity

sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24
More…