Upload succeeded but verify failed....

I recently purchased an APM2 and have been trying to upload the latest firmware to it. When I do, I get this error:


Upload succeeded but verify failed: exp C got 14 at 0


I've had the same problem using 3 different USB cables and on 2 different computers.  I've double checked that the USB baud rate is 115200.  I'm running Mission Planner 1.2.11mav 1.0 and trying to upload ArduCopter V2.7.3 Quad (I have the same problem loading any of the configurations).  I'm running on Windows 7 Home Premium.  The board has V2.4 silkscreened onto it.

I have a second APM2 which I can update without any problems using the same configuration.

Any idea how I can get this board updated properly?  Seems like a hardware problem to me.

I've posted this problem on the Mission Planner forum about a month ago and haven't had any responses so I thought I'd try here.  

I also sent e-mail to 3DR support twice (once a month ago and again yesterday) and haven't heard back.

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • I had the same problem:

    "upload succeeded but verify failed: exp 8c got DC at 102254".

    As for me, the problem happened because I use Windows VM on MAC (VMware fusion hypervisor). It's very common issue when you use Serial port on a VM.

    Try to use Windows box to upload the firmware. It helped me so potentially it may help you.

  • Hi Bruce

    Got the same error as you on my new APM2.5.  

    Did try latest software og PM = no good (Upload succeeded, but verify failed: exp76 got 21 at 2)

    Did try in CLI mode.... got this " NNNNNNNNNNNNNfN:$H@VxxxmaB;89///5Q! @ *@`5@E

    "3 989000Z(@`st: %u
    bytes free: Error: pure virtual call ?naninfovf.H?G!A??
    <??
    ````````?i3O!331!"2122h111113A3t3312223 u8:]K{~+!!!!! C!E!"s!! _!!;!-!!!! ! 7! +!!! !"m!"G! +!!! !" !! ! ! ! ! !! !!/! ?! ! ! ! !!! !!!!h"!S!!"!" !h""w!! !
    !!!e!!!) %!#!!g!"c]E?$[O
    Piz*8LQ.iz@PhrF#aXil}i-=M\{L., 1BS 5401 %&EU&QO>?9e==?
    [9rbr/>#<o<???H???U?h

    RI4]S
    @@@
    L?>S
    lll'

    *x
    9
    c@\A@A6
    L>2}~LlLlLlLl(LlLlLlLlLlLl
    @>=o;>=o;L>u< @
    #=>@
    #=>@{.>@{.>@L>,@?? @?=d @?=dL>L>@ @ @ @,
    !{NTTg })'kk~?h

    6

    6Tr!HT)}S6[
    tos{Z_i{X7-U:u;Vvs?WIYW~_si;;{IVesO/m8O)SezCbyY}+L^5?:?qwKvw~;{wrv?'\%_;{o/9[jWYs_Mg.W8!n,Y_

    Init ArduCopter V2.9.1b

    Free RAM: 2211
    FW Ver: 120
    ----------------------------------------


    load_all took 1040us
    (g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(g(  "

    Did also try Arduino with the special APM25 version = no good. Got this "

    avrdude: verification error, first mismatch at byte 0x0000
    0x45 != 0x0c
    avrdude: verification error; content mismatch " In every program uploaded code. Even small ones.

    And i have now read alot of docs, and the sad answer is that the board is conclusively doomed.

    I've only programmed it 8 times :(

    Many people have the same error, and i think it's the building of board's architecture in some way.

    I also have a Multiwii PRO and i have programmed it 100 times. And its still working.

    But now my APM2.5 goes in the bin and so does my project :.(   unless i get my fingers in one of these USB programmers.

    (in between the 8 times of programming, it flew perfectly with ALT HOLD aso)

    /Tvixen

    3692767536?profile=original

  • I managed to get it working through changing com port settings in de device settings to XON/XOFF or Hardware. Also make sure you have 115200, n,8,1 there..

  • Developer

    when you load other firmware is it always the same error? ie "got 14 at 0"

    also what do you have plugged into the apm. try and unplug everything apart from the usb.

  • Developer

    Have you tried with arduino?

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @knightsautoteam: Hi @diyrobocars, we are Orlando's first Autonomous racing club and would love your support. We are hosting our first K…
Friday
DIY Robocars via Twitter
RT @Heavy02011: #VirtualRaceLeague: @DIYRobocars Race #14 - #ParkingLotNerds join us January 15th for #AutonomousRacing #RoboRace ⁦@DAVGtec…
Jan 16
DIY Robocars via Twitter
RT @chr1sa: And after that came our races, 50 in all. This battle between these two Russians was the best we've ever seen -- incredible fig…
Jan 16
DIY Robocars via Twitter
RT @chr1sa: Before our @DIYRobocars virtual race this weekend, we had a presentation from the team that won the Indy Autonomous Challenge i…
Jan 16
DIY Drones via Twitter
Dec 12, 2021
DIY Robocars via Twitter
Dec 12, 2021
DIY Robocars via Twitter
RT @chr1sa: Just a week to go before our next @DIYRobocars race at @circuitlaunch, complete with famous Brazilian BBQ. It's free, fun for k…
Dec 4, 2021
DIY Robocars via Twitter
How to use the new @donkey_car graphical UI to edit driving data for better training https://www.youtube.com/watch?v=J5-zHNeNebQ
Nov 28, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Wrote a program to find the light positions at @circuitlaunch. Here is the hypothesis of the light locations updating ba…
Nov 26, 2021
DIY Robocars via Twitter
RT @SmallpixelCar: Broke my @HokuyoUsa Lidar today. Luckily the non-cone localization, based on @a1k0n LightSLAM idea, works. It will help…
Nov 25, 2021
DIY Robocars via Twitter
@gclue_akira CC @NVIDIAEmbedded
Nov 23, 2021
DIY Robocars via Twitter
RT @luxonis: OAK-D PoE Autonomous Vehicle (Courtesy of zonyl in our Discord: https://discord.gg/EPsZHkg9Nx) https://t.co/PNDewvJdrb
Nov 23, 2021
DIY Robocars via Twitter
RT @f1tenth: It is getting dark and rainy on the F1TENTH racetrack in the @LGSVLSimulator. Testing out the new flood lights for the racetra…
Nov 23, 2021
DIY Robocars via Twitter
RT @JoeSpeeds: Live Now! Alex of @IndyAChallenge winning @TU_Muenchen team talking about their racing strategy and open source @OpenRobotic…
Nov 20, 2021
DIY Robocars via Twitter
RT @DAVGtech: Live NOW! Alexander Wischnewski of Indy Autonomous Challenge winning TUM team talking racing @diyrobocars @Heavy02011 @Ottawa…
Nov 20, 2021
DIY Robocars via Twitter
Incredible training performance with Donkeycar https://www.youtube.com/watch?v=9yy7ASttw04
Nov 9, 2021
More…