When i attempt to upload the latest firmware to my APM2 board I recieve the message stating that upload has succeeded but verify fails.

Once I hit connect it detects the board and starts getting the parameters however it then reports my serial link isn't fast enough. I'm connecting to the board via the USB cable and I've set the speed to 115200 baud however that still hasn't resolved the problem.

Has anyone else received a fault like this or should I be looking at returning my APM2 for a replacement?

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Interesting.

    One of the two machines I tried it on is a Mac running Parallels.  The other is a Dell PC.

    I actually have 2 APM2 boards and the other one loads firmware just fine, no problems at all.

  • I have just received an APM2.5 and have the same verify error. Uploads 2.7.3 fine but fails verify at different bytes each time.

    I am using Fusion on Mac OSX running Win7.

    Works fine with all the APM1 boards I am setting up, as well as the GCS and logs.

  • I'm still having this problem.  Has anyone else experienced it?  Should I try contacting 3DRobotics about it?

  • I'm having the exact same problem.  I've tried loading the software from 2 different computers (one running XP, the other Win7) and used 3 different USB cables and they all fail verification.

    Has anyone resolved this?

  • Same problem here and it's driving me crazy. I am running Mission Planner in VirtualBox under OS X.

    Considering that the board boots and seems to run OK I am suspecting an assymmetric problem only in the direction PC. I can't imagine that a damaged firmware would boot and run for hours.

    When going online, I have about 15% packet loss on MAVLink (mostly CRC errors but also some completely lost packets). I also seem to be affected by the 'Dataflash won't erase' bug - has taken me 8 attempts to get it formated so I don't have broken logfiles after the next reboot.

    Have you replaced your APM? Was it a hardware fault?

    Otto

This reply was deleted.

Activity

DIY Robocars via Twitter
RT @chr1sa: Donkeycar 4.4 released with tons of new features, including path learning (useful with GPS outdoors), better Web and Lidar supp…
Nov 27, 2022
DIY Robocars via Twitter
RT @NXP: We are already biting our nails in anticipation of the #NXPCupEMEA challenge! 😉 Did you know there are great cash prizes to be won…
Nov 24, 2022
DIY Robocars via Twitter
RT @gclue_akira: レースまであと3日。今回のコースは激ムズかも。あと一歩 #jetracer https://t.co/GKcEjImQ3t
Nov 24, 2022
DIY Robocars via Twitter
UC Berkeley's DIY robocar program https://roar.berkeley.edu/
Nov 24, 2022
DIY Robocars via Twitter
RT @chr1sa: The next @DIYRobocars autonomous car race at @circuitlaunch will be on Sat, Dec 10. Thrills, spills and a Brazilian BBQ. Fun…
Nov 24, 2022
DIY Robocars via Twitter
RT @arthiak_tc: Donkey car platform ... Still training uses behavioral cloning #TCXpo #diyrobocar @OttawaAVGroup https://t.co/PHBYwlFlnE
Nov 20, 2022
DIY Robocars via Twitter
RT @emurmur77: Points for style. @donkeycar racing in @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/Y2hMyj1…
Nov 20, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Going to @diyrobocars race at @UCSDJacobs https://t.co/Rrf9vDJ8TJ
Nov 8, 2022
DIY Robocars via Twitter
RT @SmallpixelCar: Race @diyrobocars at @UCSDJacobs thanks @chr1sa for taking the video. https://t.co/kK686Hb9Ej
Nov 8, 2022
DIY Robocars via Twitter
RT @PiWarsRobotics: Presenting: the Hacky Racers Robotic Racing Series in collaboration with #PiWars. Find out more and register your inter…
Oct 23, 2022
DIY Robocars via Twitter
RT @Hacky_Racers: There will be three classes at this event: A4, A2, and Hacky Racer! A4 and A2 are based around UK paper sizing and existi…
Oct 23, 2022
DIY Robocars via Twitter
Oct 23, 2022
DIY Robocars via Twitter
Oct 19, 2022
DIY Robocars via Twitter
Oct 18, 2022
DIY Robocars via Twitter
RT @NeaveEng: Calling all UK based folks interested in @diyrobocars, @f1tenth, @donkey_car, and similar robot racing competitions! @hacky_r…
Oct 13, 2022
DIY Robocars via Twitter
RT @araffin2: 🏎️ After hours of video editing, I'm happy to share a best of my Twitch videos on learning to race with RL. 🏎️ Each part is…
Oct 13, 2022
More…