Uploading and Compiling ArduCopter V3.2 with Eclipse

Hi everyone,

I´ve got some problems  with compiling and uploading ArduCopter on Pixhawk. In the past I did some code modification and compiled with eclipse successfully. If I download arducopter, PX4Nuttx and PX4Firmware directories from Github, compile it with Eclipse before finally uploading the .hex file with Mission Planner I get Arducopter V3.3 developer Version all the time. But I want to compile the stable 3.2 AC Version and put my UserCode.pde modification in it.

Can somebody please help me with this???

Thanks in advance.


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • you need to checkout the version you want from git, you are currently at master/HEAD

    like that:

    andre@Loke:~/(path)/ardupilot$ git checkout ArduCopter-3.2
    then do a make px4-clean , then make px4-v2-.....

    • Thank you Andre!

      I finally solved my problem. To summarize it:

      - first I checked out ArduCopter 3.2 as you explained

      - then I checked out PX4Nuttx version 3.2

      - as I tried to check out version 3.2 on PX4Firmware it failed (I also tried to change the branch on my Git desktop to ArduCopter 3.2 with no success)

      - then I replaced the PX4Firmware Folder with this one: PX4Firmware_32

      (cloned in desktop and changed the folder name back to "PX4Firmware")

      You can find more details here:

      Problems compiling AC3.2 / Error in selecting the 3.2 branch from P...

      and here:

      Build Error --- undefined reference to `arm_mat_mult_f32'

      - after a make "px4-clean" and make "px4-v2-octa" everthing compiled fine.

      This afternoon I´ll upload it to pixhawk and have a look if it is the firmware i wanted.  ;)

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21