uploading ArdupiratesNG code help!!!

Hello all !!!

First forgive my terrible English !!!

This is my first try with APM and at this moment im very confused L so please help me!!

I use the following setup : media tek GPS 1.6 , xbees, soldered magnetometer (laptop windows 7 no drivers needed).

First I tried the arducopter way : arduino , configurator 1.22 and ArducopterNG code. As the description in http://code.google.com/p/arducopter/wiki/Quad_LoadingPage.

Everything works great both uploading and configuration , but no GPS (as commented in the site). So then I tried to upload the ArduPiretes NG to use my GPS.

My parody had started!!!

 I removed previous installations of arduino and configurator and followed the information of the site http://code.google.com/p/ardupirates/wiki/Kinderkram_instal_update and reinstall the arduino and configurator and upteded them.

Then I tried TortoiseSVN   http://code.google.com/p/ardupirates/wiki/Tortoise and i stucked at the final step about the number of revision!! What number I must use??

I finally used 549 (the ardupiratesNG revision). I made my own config.h and replace the original (my config.h flagged with a << ? >> ) and then tried to upload the code. Checked all options (port, board,serial monitor) and then upload.

After few seconds I get errors (in the pic. Attached).


Can you please help me to upload this code!!!!!



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • I wrestled with this last night actually.

    In the end I found a post in KinderKram's RCGroups Thread that stated that you need to delete the existing libraries before copying over the new libraries. For some reason, the copy, and overwrite in windows is not enough.


    The information that helped me was in this post:



  • just one question: you had arduino and configurator RUNNING WITHOUT problems, so why did you reinstall them?? :D

    ardupirates is just this new code, it runs on the SAME arduino and the SAME configurator

    but that's not your problem....


    did you install all libaries? (doesn't look like this)

  • Dimitris,


    Unfortunately, no expertise on programming on my part but I think you can eliminate possible source of the problem. Try to follow the post on cybercrash discussion I pasted below.


    If you get data out of the APM with connected GPS, its definitely not your setup but something else. If no data then at least you need to countercheck your physical setup as a possible solution to your problem.





    If you need to find out the firmware version of the gps you have, you can use the attach file to read outputs from the gps unit. Create a folder under your sketches directory and name it the same as the attached file minus the extension. Place the attached file within the created folder.




    Just use the setup you have already with the APM+IMU(OILPAN)+attached GPS. Connect your APM to the computer via usb cable. Observe the usual precaution of unplugging the outputs for the esc or hook up a battery. If you are not unplugging the esc will make some noise but you can choose to ignore them.


    I am assuming you have arducopterRC2, open arduino.exe, open the attached file, upload it to your board. When uploading is done, open serial monitor under tools, make sure the baud rate at the bottom right equals 38400 and enable carriage return.


    Look at the outputs and figure out which gps version you got:


    AXN_1.30,2389 is the January (1.6) firmware.

    AXN_1.30,2278 is the September (1.4) firmware.


    If your gps unit is defective at least you will also know since no sat fixes will be shown.


    When you are all done querying your GPS, you can reload your arducopterRC2 or ardupirateNG using arduino.


    note: 99.9% of code in the attached file is from ken. I'm just responsible for a single line :)


This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25