Hello Everyone,

I just got my APM2 this week. I was running through the steps to configure it for the 3DR Hexacopter.

I was able to load the 2.5.5 Arducopter firmware and everything seemed to be going fine. I made it to calibrating the ESC's. I found that one motor would not calibrate. After checking I found a loose connection with a deans connector. I disconnected everything and then soldered a new one one. Now had power at the ESC.

I went to try and calibrate my ESC's again and it would not calibrate any of them. I noticed that the tx and rx LED's were no longer blinking and the red and blue LED's were blinking. I figured I'd unplug it from the battery and plug in the USB to see what might be going on.

Now it does not even get recognized that it is even plugged in. I get power and the red and blue blinking LED's but no communication. I read through all the things I could find but didn't see a definitive answer.

Seems to get GPS lock as that light goes solid blue but now the red LED just sits and blinks with the blue one next to it just on solid.

Any Ideas of what happened and what to do now?

I tried different cables but the red LED concerns me.

Any help would be great.

UPDATE:

I went to the multirotor event on the 17th of June. I got to meet a bunch of great people. The guys from 3DR were there and very helpful.

It was amazing to see these things in action.

Just wanted to say thanks to Sam from 3DR and Chris for all the help.

I have a new or fixed APM2 on the way.

Thanks again 3DR.

Thanks,

Jeremy

Views: 4045

Reply to This

Replies to This Discussion

You are correct. It was working. After i connected the APM2 back up to the power board it was not working anymore.

I am not sure it is the USB as it does not seem to boot. Could the Atmega have lost it's mind? I did find that sometimes if there was a power glitch it may mess it up and then you have to reload the bootloader.

It would be nice if there was a blink error code list. I didn't see one. What does a constant blinking red LED mean?

Thanks again for the response.

Jeremy

Any help would be greatly appreciated.

Thanks,

Jeremy

i had the same problem a few days ago, seems like the problem is with the 32u2, the communications chip. unfortunally, i've had to send it back to the store, and 3dr replaced my apm2. by the way, special thanks for Carmen that offered a really fast support and solved my problem.

you can try this tutorial here: http://code.google.com/p/ardupilot-mega/wiki/APM2Encoder , if it doesn't solve your problem, contact 3dr help.

I have the exact same problem and the tutorial listed requires USB connectivity...  so it is useless.

I contacted 3dr and was told they don't fix them...  I'm SOL.

I looked at that and then tried it. Still same thing as I can not connect by USB to reflash it.

I did send a request to the 3DR support but haven't heard back yet. It's the weekend though so not sure if they work weekends.

Here is a video that shows what it is doing.

Thanks,

Jeremy

Incredible.  I was just putting the finishing touches on my second APM2 when the same thing happened to me again.  This board that just died is a replacement that 3DR sent me only this past Thursday.  So this has happened to me twice now.  And I'm no dope--I follow instructions carefully, triple check my connections, measure voltages before connecting devices...

My frustration is overwhelming tonight... I was so glad to have put the last one behind me and get this purple beauty into my plane, and now AGAIN the issue returns.  I don't want to abandon the product--I love how robust and powerful the system is.  It's really a marvel.  But what's going on here??

I'm not sure I understand what the issue is. Is it that the boards are frying when you apply power? Can you think of anything that could be causing this? I've used dozens of them and have all sorts of funky power sources, but have never fried a board. (The only way I know of to do that is to plug in a RC connector with one pin offset, so the +5v line is on a signal pin -- 3DR is going to be shipping them in enclosures soon so people can't do that). 

That really stinks. I hope to hear back from them today on what we can do on mine.

I am hoping it is not fried just lost it's code on the chip. If it is just that then maybe it can be reflashed using the programer that I read the how to on. I live close to Sparkfun and may have to stop by and ask them to take a look.

The only thing that I had to unplug and then plug back in was the power board connector which I double checked before powering up. So hoping it was just the rare glitch that can wipe the 32u2. Also hoping it never happens again.

Spagoziak did they happen to let you know what it was. I was thinking it just lost the programming not actually damaged anything. Was that the case or did it actually hurt something on the APM2?

No reply yet from 3DR. Hopefully I hear from them soon. I really wanted to go to the Sparkfun event this weekend.

This thread seems to have similar results of what we are seeing from the LED perspective anyway. The red and blue blinking LED's and then just the red blinking LED.

http://diydrones.com/forum/topics/problem-with-apm2-powering-up-my-...

I seem to have voltage at both input and output pins though unlike he had.

Thanks,

Jeremy

Hi Chris, thanks for writing.  

Not fried, exactly... just all serial connections are purely unresponsive.  I'm using the JP1 jumper to power both ends of the board with one source.  It's a BEC that I measured out at 5.08 volts.  I've used that same BEC for both the 1st APM and the 2nd one.  The 1st one enjoyed hours of me fiddling with HIL and waypoint navigation.  I always power the BEC from a 3S Lipo so I can avoid oddball power surges and the like that could come out of an AC/DC adapter.  

The 2nd one spent less time around, having failed only 3 days into having it.  The thing still works, in the sense that it will do whatever is stored on those chips.  However, there is no way to interact with it any longer.

I think I have the same problem.

I have been using the APM2 for 4 months. Usually use the Xbee to change settings and record flights. Last night I come to connect and nothing. I did 3 flights as is then tried to connect with the USB and was surprised when it to could not connect. Up to this time I had no problem. When I try to flash the firmware I get an unable to determine APM version. I was unable to do a lot of troubleshooting last night and will try some tonight.

The board is useless if you can't talk to it.

Emile L.

I did hear back from 3DR. Not exactly the help I was looking for. Hopefully they come back with something else.

They said to try and use the tutorial on programing the 32u2 with USB. They added if I can't do that to program it with the SPI programmer.

I don't know what the SPI programmer is or how to do it. I did read through the programming the ATmega chip for the first time but don't think that is the same thing. It is located here.

http://diydrones.com/profiles/blogs/tutorial-getting-those-pesky

I even ordered the programmer recommended there.

So if anyone has any help on how to do this that would be great.

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service