v3.1.4 compass calibration issues

I seem to have had this issue before, but can not remember what I did to fix it. I load the new firmware on 3.1.4 and everything is fine to I get to compass calibration. I have turned that quad everyway possible and have hit over 6000 samples but it just keeps saying need more samples. If anyone could help me out with this I would be extremely grateful.

Thanks you for your time in this matter,


You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Hi Craig .. Ok I have some tlogs .. I think the first two are trying to calibrate internal the  last one is with external compass calibration and successful flight including rtl.

    2014-05-27 10-31-27.tlog

    2014-05-27 11-42-41.tlog

    2014-05-27 14-15-06.tlog

  • Developer

    @Ruben please post a tlog from your compass calibration so we can analyze what is going on.

     @Everybody, please update to 3.1.5

  • I'm using the AC3.1.4 , previously was on the 3.1, I already had saved by parameters , including compass calibration, compass mot, accel calibrations, etc. I cleared the EEPROM to erase my old firmware. Of course I saved my settings first. Insatlled the AC3.1.4 then loaded my previously saved parameters, all good to go. Just a few Minor tweaks on rate and stab. Flies we'll, loiter is solid even 5 feet off the deck.

    I suspect the issues on compass calibration could be more related on this newer mission planner version. I calibrated my unit using the 2.99 MP
  • Ok Guys I have a very interesting problem most likely to do with the Pixhawk than the firmware .. could also have something to do with the compass cali in MP going bad.. here is my story. 

    Just built a new machine (one of many) Finished set up and it was flying quite well, including a demo to the customer and interested parties.. (copter has been built for weed spraying etc) we were invited to do a demo at Scion Institute the following week , so we went down there and flew , but I noticed GPS was not holding well (copter trying to fly off) and Mag field was too low, so I could not use Loiter mode .. However upon returning home I plugged the Pixhawk (supplied by 3DR) into the Laptop and checked Mag field  and checked Compass .. weird thing was the compass did not seem to be moving correctly in the HUD .. anyway after trying several times to re calibrate the compass each time failing, I noticed the onboard compass was only showing pixels gathering on one (1) axis on the MP calibrate screen .. MMmm, so I though the compass must be corrupt ..so did a full reset and erase and started right from the beginning..once again when it came to calibrating the compass it was only showing activity on one axis on the new fancy MP Cali screen.. So I thought the compass must be DEAD, so I fitted an external Compass and redid the calibration .. having to do include the new  upside down move..and the calibration this time was fine ..I did a test flight and the Loiter held just fine , previously it would try and fly off to who knows where !   So wtf ?

    The mag field was an interesting one too .. I could not figure out why I was only getting 220 - 270 strength.. started trying all sorts of stuff , long story short was I had the short 90 degree mini lead plugged in so I could access it easily .. well due to it being 90 degree plug it meant that the lead had to go around the front of the pixhawk  and terminate towards the rear .. so it lay neatly under my dome, well after removing the extra little usb lead .. the mag Filed jumped up to 680 instantly .. Note: the USB lead was not powered it was just sitting there.. So the lead was affecting the mag field alot ! I will note i had already removed this lead when trying to calibrate the onboard compass so it was not the reason why the compass is not working ..  

    Any thoughts ?? Anyone have similar issues with the on board compass going dead ?  At least you know now what to do the when you see the mag field too low ( remove any thing you have in front of it )  in my case a short mini usb lead.

    Regards Reuben3701744358?profile=original

  • Admin

    Hi Michael,

    Please find attached a 7-z compressd file of the tlogs and data flash log that I captured during my failed attempt to calibrate the external compass on my APM2.5.


    TCIII ArduRover2 Developer


  • I downloaded the newest Mission planner which came out yesterday morning and it was fixed. Thank you.

    • Admin

      @ Donald,

      I updated my MP 1.3.3 to 1.3.4 yesterday and added the latest updates this morning and I am still getting the "Insufficient data points" message after collecting over 700 data points.

      It looks like it may take a fresh install of MP 1.3.4 to resolve this issue?

      Just did a fresh install of MP 1.3.4 and still get the same message with almost 900 data points!


      TCIII ArduRover2 Developer

      • It took me 1500+ data points on my 15+ lb copter!

        The points need to be covering all areas of the sphere too!

        Needed to watch where it was collecting on the display carefully.

      • I just went off of what another member told me. I downloaded the new MP, hooked up my APM, went into setup and erased, installed the new firmware and then the compass calibration worked. I still had to go up to almost 1000 data points but it finally took it after about 2 minutes of rotating it.

This reply was deleted.


Neville Rodrigues liked Neville Rodrigues's profile
Jun 30
Santiago Perez liked Santiago Perez's profile
Jun 21