Very strange Pixhawk problems on Octocopter

I am having very strange problems with Pixhawk on an octocopter:

1. When I arm the copter and start flying, the Pixhawk beeps and Mission Planner shows NO GPS / Bad Compass Health. The problem mostly occures when I start flying. This problem has occured few times without arming, it just shows NO GPS / Bad Health. I have tried two original (new) GPS/Mag units + NEO 7 and the problem stays. When the copter is disarmed it does not show any errors and I have 3D Fix

2. Pixhawk shut the motors off - on last flight I got the NO GPS / Bad Compass Health error on taking off and decided to see what happens - I hovered on the height of 3 meters for a few minutes and suddenly all the motors shut off and the copter fell like a rock. 

Extra notes:

Pixhawk firmware - latest stable (3.1.5)

I have tried two different Pixhawks, problem still exists.

The Pixhawk is powered by Castle Creations 10A BEC (Power Module port) and there is also one ESC BEC connected (BlueSeries 40A). 

Spektrum TM1000 and one Arduino Mini Pro is powered from the servo rail (by the ESC). 

What could be the reason for this behavior?

In addition - line 47 914 seems vey weird in the log file.

Log file included (last flight with crash).

2014-10-15 17-01-39.log

2014-10-15 16-55-14.tlog

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • Issue resolved. Three GPS units were faulty (loose battery inside the GPS plastic box).

  • Check for loose cables and possibly replace the cable to your I2C expander.

    • Which cable could be loose? I've tried two different Pixhawks and three GPS units. I2C expander is not in use. Mag is connected directly to Pixhawk's I2C port.

      My own guess is that it has something to to with the connected ESC BEC and/or the devices that are connected to the servo rail and ae powered by the ESC.

This reply was deleted.


Shivchand Jaysaval liked Shivchand Jaysaval's profile
Aug 25