Video with Gimbal Shaky

Hi,

I have a custom built F450 frame with a Pixhawk to which I have attached the famous great cheap Goodluckbuy gimbal (the 70$ one with Storm32 controller) and a Gopro Hero 4 Silver. I have done some PID tuning for the gimbal (well actually mostly took PIDs from others with the same gimbal and much more experience on some forums), but the video is still shaky and I guess it is from the PIDs, not anything that this gimbal cannot do from what I know.

Here is an example video I just took: https://www.youtube.com/watch?v=jDF1Jb-zMCY

I have also attached the PIDs that I am using for the gimbal.

Can you please give me any ideas on what to still work on? I don't have experience so I cannot tell if the shaking (mostly the vertical one) comes from a too low P maybe, or is overshoot from a too high P? Or shall I work on I and D some more?

Thanks!

working-pids.cfg

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Its a very windy day but my opinion would be the dampers.  Like Harry said to soft or to hard.  If they are hollow roll up some ear plugs and insert them into the dampers and see if it gets better or worse.  I use a Feiyu tech gimbal on my F450 and with ear plugs inserted into the dampers the video is spectacular.

    Regards.

    David R. Boulanger

  • Rrayden,

    I also have a large homebuilt Y6 with a 2 axis gimble with the storm 32 board.  I still struggle with shake in the video.

    I don't think your shake is too bad.  To improve the shake I would not look at the storm 32 PID's but more physical issues,  

    vibration dampening is to soft? to hard?

    bending in the mounting or frame of the drone?

    vibration from the props and motors that could be balanced better?

    These issues will all ways exist, we can only try to minimize them, particularly with the home built drones.

    In my case, I attribute my remaining video shake to the method of mounting of the camera gimble to the frame.  However, Im not ready for a rebuild yet.  I'll improve my connection on the next rebuild.

  • bump

  • bump
  • Oh sorry... i have set it now to Public
  • Might be because you have the video set to private?

  • no one has any hint? :)

This reply was deleted.

Activity

sam liked Jimmy Oliver's profile
Aug 25
Mike Whitney liked Mike Whitney's profile
Jul 19
Abdulatif Tlaib liked Ryan's profile
Jun 24
More…