Hi folks. I've built several models using the MegapirateNG project. Recently I realized that all my models exhibit an alarming behavior when switching from Stabilize to any auto-pilot mode (RTL, Loiter, etc).

Say I am flying my F450 forward at a good clip, 20 MPH or so, and I switch from Stabilize to RTL. My model will violently pitch its nose up.. like, vertically, then wobble around trying to get stable.

It loses a lot of altitude while doing this. It's pretty scary to watch.

With my F450, it eventually recovers, flies up to RTL altitude, and comes home.

I have a "Reptile" quad (TBS Disco clone) that, when going through the same correction, will not recover. It wobbles around until it hits the ground.

I thought maybe I had my PIDs set too aggressively, so today I set them all back to their defaults. My F450 still pitches up violently when changing modes.

I've tried everything I can think of. Is this just a characteristic of Arducopter and I have to live with it? I have one F450 that has a Naza M Lite in it, and it doesn't do anything like this when switching modes. I much prefer ArduCopter.

MegapirateNG is based on ArduCopter 3.0.1-R4 (555f662)

Views: 538

Reply to This

Replies to This Discussion

No one sees this? Or, everyone has accepted it?

I just had this cause a wreck on my hexacopter.  It really is quite annoying.  I'm not sure what parameter needs to be changed though.  Wish I could help more.

Brian, that was resolved long ago with ArduCopter. The problem is that the Megapirate code is several generation behind the main project. I'd suggest you upgrade to ArduCopter 3.2 and the issue will be resolved. 

Running MegapirateNG or stock ArduCopter? I tried changing Loiter P, seemed to have no effect. To me, this seems like a too-strong P and too-weak D, but can't figure out where. I do see Loiter Rate has PID, going to try that next (just noticed its default D is 0.. hmmm wish I had a better idea what these were).

Thanks! And BTW: thanks for all your tireless work in our hobby.

It's Arducopter.  I haven't tried to change anything, but I'm really afraid to use RTL now or go near the end of my radio range and hit the failsafe.

I have seen very recent (3.1.something or 3.2, not sure) diydrones versions of ArduCopter do some very abrupt maneuvering at the end of a mission too. I am pretty sure my gimbal would have fallen out of its rubber absorbers if it had been on board. So I can confirm there may be a regression here.

Regards

Soren

Its been awhile since i dragged out my old NG board but i think if your up to date with the software 3.0.1 has "ANGLE_RATE_MAX" that's defaulted to 18000 so maybe try something lower like 10000 and see how it feels switching between mode's.

At 6:50 in this vid there is an example. This is a very recent ArduCopter version, reaching end of mission.

At 4:30 there is an intra mission sharp turn (at the same place; the mission was 2 times up and down that hill) and that is done smoothly enough.

Camera is not straight because gimbal was off (and the gimbal did not fall off this time :)

Regards

Soren

3.1 did that... 3.2 does not.  Mission end is now smooth.

Hi, OK thanks. I will try see the exact version when I get it back and upgrade to 3.2 & see if that changes it.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service