Hello, 

So i'm having a weird problem with Taranis, dragonlink, ppm, or pixhawk I'm not sure really what it is.

I'm using a Taranis controller, dragonlinlink TX/RX PPM to pixhawk. My quad flies great, tested in all modes. all channels operate correctly in the RC calibrate screen. 

I'm using 6 channels, but gimbal tilt is mapped to channel 7, with channel 6 doing nothing.

My problem is, when I move the gimbal slider all the way in one direction, to make the gimbal look up... my pitch and roll stick become reversed. IE when i push the pitch stick forward, instead my quad rolls to the right. and when I pitch back, instead my quad rolls to the left.

Now if i move the gimbal slider back down so the gimbal looks down, the controlls return to normal, and pitch controls pitch, roll controls roll.

I tried to recreat the issue while the quad was disarmed. While lookling at my RC calibrate screen, i moved the throttle to mid stick to simulate hover, and moved the gimbal slider all the way up to make the gimbal look up. When i move my pitch stick forward, pitch moves as it should, not effecting roll at all on the RC Calibrate screen. But sure enough, when i try to actually fly again.... When I make the gimbal look up, my pitch stick starts making the quad roll instead. 

I'm guessing this has to do with PPM framing or something with my PPM signal, but that's really just a guess and i'm not sure. My taranis PPM setting is set to CH 1-10, 26.5ms 300u +. I've tried changing it to CH 1-7, and also increasing my pulse legnth, but still the same problem.

Any ideas? I'm lost.

Views: 1196

Reply to This

Replies to This Discussion

Make sure you re-bind your Dragonlink RX every time you change anything about your transmitter's PPM stream.

Thanks I will try re-binding my TX/RX but i find it very strange everything shows up correctly on my RC Calibrate screen, but acts differently when I fly. 

This problem only happening when the gimbal is in the UP position.... very strange 

It's possible your gimbal is hitting the stops and drawing too much power causing some sort of brown-out.

So i had another test this morning, I re-binded my dragonlink rx/tx and i un-plugged the gimbal control cable from the gimbal controller, so when i command the gimbal to look up it doesn't actually do anything. 

When i first take-off.... it flies fine, everything responds as it should.

Then during the flight, after about 1-2 min of flying, suddenly, the controls on my pitch/roll stick become reversed. pitch forward now makes the heli pitch back. Roll right and left is also reversed, but ONLY while i have the gimbal pot to the look up position. if i move the pot back down, it flies normal again. (good thing! IT's hard to fly with reversed pitch/roll!)

VERY confusing......... I'm still at a loss. It flew fine the first min of the flight even with the gimbal pot in the up position. Then suddenly the pitch/roll stick became reversed after a min of flying, gimbal pot down, and it flies normal again. 

I've only ever tried sending 8 or 12 channels with the Dragonlink, not 7 or 10.  I suggest you try one of those two.  For 8 channels you want around 22.5mS frame length and for 12 channels you want 31.5mS.

Problems like you mention could definitely happen if your frame length is too short but it sounds like you already tried longer frames. Maybe you didn't rebind in that case though.

Well i just tried another test, I changed my PPM settings to 1-12ch, 30.5mS, 300u negative pulse. Re-bind TX/RX.

The problem is still there, but not as bad. Sticks are no longer reversed. Only when gimbal pot is pointing up,   when I pitch forward stick, the quad will pitch forward and slightly to the right at the same time. And when I pitch back stick, it will pitch back and slightly to the left too.

I flew like that for a few min, then i decided to try alt-hold. Same thing. Okay, then i tried out position hold. I had no control of pitch/roll in position hold! and according to my groundstation, the quad remained in alt-hold, and never actually switched to position hold. If i tilt the gimbal pot down, the quad will switch to position hold and i have control of pitch/roll again.

Just noticed you said to try 31.5ms so i tried that, and same problem. sticks are messed up only when gimbal pot is up. I tried 1-8 channels with 22.5ms and same thing. I've memorized the re-bind procedure by now :)

I had another thought.  Do you have any of your limits extended?  Maybe you're trying to send PWM values which are too long or too short.  Are any of your channels set to output more than 100% range, especially that gimbal channel?

 

I still think you're making a bad PPM stream somehow and causing the pulse train lose sync.

I agree it's got to be some setting or something with the PPM stream... Just checked all the channels and they are at 100% except my ch5 flight mode switch is only on 65%. Should I change that to 100% as well? 

I tried using the PWM outputs on the dragonlink RX, going to pixhawk using the 3dr ppm encoder and same thing, just thinking maybe the dragonlink rx was outputting a bad signal.

If you have access to an oscilloscope, it would be simple to look at the pulse stream your taranis is outputting to the DL transmitter and see what happens when you move that gimbal to it's limit.  That would remove some variables.

 

An alternative test would be to use another Frsky receiver like an X8R in S.Bus mode or a D4R-II in PPM mode and see if the problem persists.  If so, it's probably an electrical problem on the aircraft.

If you want to post your EEPE for the model I can take a look at it.

I assume you mean the file for my quad model on the taranis? Here you go. Thanks for the help.

Attachments:

I looked at your settings and don't see anything odd.

I'll try it with a Taranis and Dragonlink tonight when I get home to see if I can reproduce your issue.

 

In the meantime, here's a config for arducopter I did almost two years back which supports 6 flight modes and announces them.

http://rcsettings.com/index.php/viewdownload/6-multirotors/33-arduc...

 

That one is set up for the internal module but you could just turn on the external PPM and turn off the internal to make it work with your Dragonlink.  You'd also need to turn off the A2 voltage warning settings.

After seeing how simple your Taranis setup is, I'm leaning towards this being a problem with your gimbal pulling too much current when you tilt it up.

 

You're not trying to power a servo from the Pixhawk current sensor are you?  It doesn't provide enough current for that and you will have brown-outs for sure.

 

The PPM port on the Pixhawk is powered from the current sensor.  If you use that to power your RX then connect a servo directly to the RX you will have major glitchyness when you move the servo.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service