Hi,

I am trying to display data generated by Matlab in the Mission Planner. I have written a C-based S Function to transmit MAVLink v1.0 data from Matlab using UDP to Port 14550.

I am able to receive this MAVLink v1.0 UDP data using QGroundControl. I am also able view the information (roll,pitch, etc) sent.

However I am not able to display the same data using Mission Planner. When I click "connect" the planners says "waiting for UDP" and waits forever.

What takes place when "connect" is pressed in the Mission Planner. What is the data transfer process used by Mission Planner. Please help me solve this problem.

I am using MissionPlanner-1.1.92 and I have also tried the latest versions.

Thanks,

Mahesh M.

Views: 1633

Reply to This

Replies to This Discussion

please try connecting using "control-T" see if that works

Thanks Michael,

Control-T seems to work.I am able display the roll,pitch,yaw attitudes on MissionPlanner-1.2.11

But sometimes I get the following message:

Getting Params sysid 1 compid 200
Connect Failed

Details:
Timeout on read -getParamList
650 packets were received, but no parameter packets were received.

Are there some specific packets that APM Planner is expecting?

I am sending the following packets 10 times a second:

mavlink_msg_heartbeat_pack

mavlink_msg_sys_status_pack

mavlink_msg_local_position_ned_pack

mavlink_msg_attitude_pack

Thank you again,

Mahesh M.

your script doesnt implement the parameter exhange properly.

Hi Michael, could you please tell me where can I get the details of the parameter exchange process so that I can implement it.

Mahesh M.

Thank you Michael. I shall try this and get back.

Mahesh M

Hi Mahesh,

I just met the same problem you had in this topic "Params sysid 1 compid 200". I checked my parameter exchange and I think it is managed in the right way. How did you solved you problem?

Thanks!

Hi dear

I would like to help you but unfortunately i cannot and I want to ask you for the help.

actually i want to make a s function which mavlink protocol is used in there

I want you to send me yours if possible to use it as a sample

sorry for the request

thank you so much

Hello

I am trying to connect Simulink and Mission Planner. i have been successful in creating a UDP connection and i am receiving the Mavlink messages in Simulink model. Now i wanted to send back the commands from Simulink  to MP.  Does anyone know what settings are required in Mission Planner to receive Mavlink messages from Simulink? How to use "connect - T" to make connection.? any help and guidance is appreciated.

Reply to Discussion

RSS

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service