Why are motors not getting full power from arducopter

Arducopter is limiting the total power output of my hexacopter to 37 amps when it has the potential for 66amps when at full throttle.

I bench tested many different motor and prop combinations to see which would be the most efficient for my arducopter hex 550.

I decided to use 6 x 1000kv motors with 9x4.7 props which deliver 710g of thrust at 11amps each at max throttle.

Why is arducopter limiting my throttle current draw to 37 amps when the max should be 6motors x 11 amps each = 66 amps.  (see mission planner tuning chart)

I understand that the controller needs reserve power for controlling stablization but 37 amps is only 56% of total power potential that could be used.

I have calibrated my escs many times thinking that was the problem but its not.

When i use my kk2 controller on the same hexacopter i get 52 amp draw at max throttle held down on the bench.

Is there a setting that i need to change to allow the controller to use more potential power.

I want to put more equipment on this craft but it needs more power.

Thanks in advance for your help.

the Chart below shows thrust output for each motor/ prop combination.

I decided to use a 1000kv motor with a 9x 4.7 prop. next chart

3690986315?profile=originalThis chart is just the 1000 kv motor with 9x4.7 prop  

max thrust was 710 grams at 11amps

3690986145?profile=originalI went into the tuning page for Misson planner and see that at full throttle i am only drawing 37 amps for 6 motors.  Hexacopter held down at full throttle on the bench while connected to MP.  the hex draws about 25 amps at hover with no extra equipment on board.

3690986336?profile=original

why is arducopter limiting my throttle current draw to 37 amps when the max should be 6motors x 11 amps each = 66 amps.

I understand that the controller needs reserve power for controlling stablization but that is only 56% of total power potential that could be used.

Is there a setting that i need to change to allow the controller to use more potential power.

3690986291?profile=original

3690986349?profile=original

2013-01-12 08-43-58.tlog

2013-01-13 16-39-04 tethered to pc flying hex.tlog

You need to be a member of diydrones to add comments!

Join diydrones

Replies

  • Hi there,


    We're getting the same problem using an contra rotating motor on Arducopter 3.2.1, powered my APM 2. When using calibrating mode for the ESC's, the motor get full power and seems able to rise. On the other hand, when trying to fly the UAV using the CoaxCopter firmware, motors doesn't get full throttle and barely try to climb. Have anybody solv'd that?

  • I ran into the same issue with APM 3.2. After reading through all available forums I think I found the resolution to this problem.

    First, check the PWM input value for Channel 3 and compare it to the output values for Ch1-4 in the status monitor. In my case, Ch1-4 out never exceeded 1500, regardless of the Ch3 input.

    Apparently in some installations 2 parameter are set to wrong values, THR_MAX and MOT_TCRV_MAXPCT.

    In my case, THR_MAX was preset to 80 (default is 800 -1000) . Resolution: set this value to 1000

    Aso in my case MOT_TCRV_MAXPCT was set to 40 (range 0-80). This limits throttle to 50%. I set this value to 80 and suddenly had full power.

    Re-check Ch1-4 out at full throttle. Now you should read a PWM value of ~1900 and you should be good.

     

    I am still interested why those values are set up wrongly in some installations......

    I am using APM 3.2, but had the same issue with APM 3.1.5

    • Thank you for this post. The MOT_TCRV_MAXPCT I've never hear about before. Mine was set to 93 when it clearly says in the parameter list the highest is as you say 80. Changed it now and will se if it makes any difference. =)

      My previouse solution has been to calibrate the ESC's from TX at 1900 PPM max value.

      • Throttle curve was made to try linearize ESC output, that usually has it's last 7-10% output same value.

        Instead of changing MOT_TCRV_MAXPCT to 80 (default is 93) try disabling throttle curve by setting MOT_TCRV_ENABLE to 0.

        Emile

        • Okej, thanx for the tip. But why is the default value 93 if the range is only up to 80? Would there be any difference between 93 to 80 or does 93 get interpreted some other way?

          • Because on bench tests the majority of escs was at full throttle with 97% of the maximum PWM.

            So the throttle curve tries to linearize this curve and give full PWM at 93% of throttle.

            Throttle curve does this to find the maximum PWM:

            int16_t max_thrust_pwm = radio_min + (float)(radio_max - radio_min) * ((float)_throttle_curve_max/100.0f);

            where throttle curve max is the parameter : MOT_TCRV_MAXPCT

            and radio_min and radio_max are your radio calibrated parameters.

            P.S.

            MOT_TRCV_MAXPCT range is 50-100....
            If not update your mission planner to get the latest oparameters defaults.

            // @Param: TCRV_MAXPCT
            // @DisplayName: Thrust Curve max thrust percentage
            // @Description: Set to the lowest pwm position that produces the maximum thrust of the motors. Most motors produce maximum thrust below the maximum pwm value that they accept.
            // @User: Advanced
            // @Units: percent
            // @Range: 50 100
            // @Increment: 1

            • okaj, that was a good explanation. Nice to see the code as well.

              But from there. Should not the APM calibrate the motors accordingly to its maximum output? 

  • Hi, have any of you guys solved the problem? I have tried everything in my power to fix this but going back in firmware. Was out today flying and had even less power than before I tried to fix this problem. Copter would not even lift when battery was below 11V (running 3S) and with the same frame and a MultiWii board I've been doing flips before without any problems. I don't have an Amp meter to try things out but its obvious the system is not using its potential. 

    We've been discussing the same issue in this thread

    • I too am having this problem. Our drone is a quad with 12 batteries. It was very sluggish but it was designed to lift a load. Platform was stable, timed well. Running 3.15 firmware after an update I am not sure if it was windows or mps

      I am suddenly having this throttle problem. I built a duplicate drone and tested  with the current firmware, it behave identical to the previous unit so this is definitely a software problem.  Since we hover at 60-70% throttle I wonder if the updates to 3.15 redefined the throttle parameters are causing this problem.

      Could use a little guidance. Thank You

      • After attempting to fly and only barely achieving liftoff on what should have been a very healthy platform, I dove into the data and saw the pixhawk commanding about 1800pwm on the servo output channels at 100% throttle command . The radio gives 2006 PWM at max throttle and I believe this is what the ESC's are calibrated to, having calibrated them through the pixhawk process.

        I then plugged in another data-logger and measured max power during the esc calibration process and saw roughly double the power I could get in normal mode.

        I fidgeted with a bunch of stuff to no avail. I finally decided on a "hack". I set the end-point of the throttle to approx. 1800 max, re-cal'd the radio, re-cal'd the ESC's, set the radio back to 2006 max, re-cal'd the radio again, and BAM, FULL POWER. Almost double the battery Amps.

        I still see the pixhawk only commanding 1800 or so on the outputs, but at least that now correlates to 100% throttle as far as the ESC is concerned.

        There is definitely something funky going on, where the pixhawk refuses to command max PWM no matter what I've tried.

        I have yet to fly this setup, but I think it's gonna work.

This reply was deleted.

Activity

DIY Robocars via Twitter
Sep 9
DIY Robocars via Twitter
RT @chr1sa: We've got another virtual @DIYRobocars race tomorrow at 9:00am PT. Two dozen autonomous cars will compete, four at a time. Ther…
Sep 4
DIY Robocars via Twitter
Sep 1
DIY Robocars via Twitter
Aug 31
DIY Robocars via Twitter
Aug 31
sam liked Jimmy Oliver's profile
Aug 25
DIY Robocars via Twitter
RT @ExplorerRobocar: Sometimes, I am really a big kid!! Having fun with my virtual RC car on the @diyrobocars track 😜😉, by using the « AR R…
Aug 24
DIY Robocars via Twitter
RT @grepLeigh: @donkey_car @unity3d @TensorFlow ~1050 episodes into training, my agent learned to erratically drive in the left lane. 🤖😆 ht…
Aug 24
DIY Robocars via Twitter
RT @EclipseCyclone: Sweet! http://Robotec.ai high performance #ROS 2 @unity3d #CycloneDDS bridge for @AutowareFdn @SVLSimulator now…
Aug 24
DIY Robocars via Twitter
RT @a1k0n: My car had a lot of trouble getting around the track at the last @diyrobocars event -- only one actual finished lap during the r…
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map https://t.co/VzykOkUt2G
Aug 24
DIY Robocars via Twitter
RT @SmallpixelCar: Made a lot progress on Warm Spring Raceways track. Almost finished one lap. https://t.co/nUVpufZQyP
Aug 24
DIY Robocars via Twitter
RT @AntonioRobotics: Super fun time seeing these autonomous cars race at @circuitlaunch for the @diyrobocars quarterly meet up! The demolit…
Aug 15
DIY Robocars via Twitter
RT @a1k0n: I thought my dumb localization code was still working at the new @circuitlaunch track, but it was just *barely* working. I shoul…
Aug 14
DIY Robocars via Twitter
RT @DAVGtech: Recording of entire in person @diyrobocars race today @circuitlaunch. Fast forward a couple hours to go straight to the racin…
Aug 14
DIY Robocars via Twitter
RT @SmallpixelCar: This is the run time map. Very noisy Lidar signal https://t.co/bAbeVUMi10
Aug 14
More…