When I switch into RTL mode APM immediately cuts my throttle to zero.  My Sky Fun Jet does a beautiful job of gliding back to launch and circling, but the throttle never comes back on.  I am guessing that APM cuts the throttle to descend, but shouldn't it power back up before reaching the ground?  It's almost as if the commanded altitude is below ground level.  Perhaps my cruise airspeed is set to low (10 ft/s) and the throttle is cut in an effort to slow down?   I bumped it up to 15 ft/s but have not had a chance to try flying again yet. Any suggestions?

Views: 2475

Reply to This

Replies to This Discussion

Yes, the throttle should come back on when the aircraft is at the requested altitude and speed. Your cruise airspeed is indeed very low for a Skyfun. I'd set it to at least 3x that, and ideally 5x.
Chris, thanks once again for your help. Am I correct in thinking that the RTL altitude is set "automatically" to some value above the launch altitude, and that I shouldn't have to worry about setting it somehow? As for the cruise airspeed, I bumped that up in my APM_config.h file. Per your suggestion, I will increase it even more.
Default altitude is set in the Mission Planner:

So this altitude gets applied in RTL mode as well as Auto mode. I was not aware of that. And if I remember right, the units in this box are meters?
Guys, I too am having this problem and I would appreciate any advice.


When ever I switch to Auto my motor switches off completely, it does an wonderful job of keeping the plane stable and trying to get to its waypoints, but doesn’t get very far due to no power.


I've tried setting the Airspeed m/s higher in the AMP PID config and tested on the ground, but not had any luck.


I would really appreciate any help or pointing in the right direction.



Might be any number of things, including a reversed throttle channel and accidentally setting altitude to zero.

Did you do a radio setup in the CLI?

Does it work in RTL mode?

Hi Chris


Yes, have performed the radio setup in the CLI and seems to be ok, would you like to see the results?


It doesn't work in the RTL mode either. I have also reversed the throttle channel and no change.


I ran the Radio test in the CLI and I can see in "in channel 3" the data moving up and down, how ever on the "out channel 3" I see 0 until I get to mid throttle then 100 at mid throttle then going past mid throttle it goes back to 0. The results are reversed if I disable throttle reversed, so it goes 100 - 0 - 100. Does that indicate to you that there is an issue? or is that normal output data?




That is not normal output.  Try the radio setup in CLI again and make sure you cycle the throttle stick through its full range.

Thanks Doug, I didn't think it was normal.


I have have been through the Radio setup in the CLI and i'm still getting the same output.


Any ideas?


Strange mixer or other setting on your TX?
Yes, it sounds like an odd TX setting. Carlos, please post all your CLI radio setup data.



I don't really know what to say......have just run the Radio test in order to copy the data to show you, and it is now showing normal data! I have sat here trying to think what has changed and I can't get my head round it, as I have not made any changes since my last post. Now when I move the throttle up I see the data changing from 0 to 99 normally. I have also tested to see if it still cuts out when switching to Auto and it works perfectly fine. So issue some how resolved!

I want to say first of all thank you very much for all of your support, Chris and others. I don't believe things just fix themselves so when I work out what happened to make it work ill update on this thread, so at least others can benefit should they have the same issue.



Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service